manuale Willer

Elvis Elettronica Video Suono snc
Via Ippolito Nievo 5, Caselle
35030 Selvazzano Dentro (Padova)
 Posta elettronica
Pagina WEB

Willer

versione 5.3

Vai all'indice

Grazie per aver scelto WILLER, un software realizzato da Elviselettronica per semplificare la gestione dei servizi a pagamenti della biblioteca multimediale.

Il programma è suddiviso in moduli che integrano le seguenti funzioni:

  • Emissione immediata delle Tessere Utenti con foto a colori
  • Abilitazione all'accesso ai servizi della Biblio-Mediateca con diversi profili (categorie) di utente
  • Calcolo dei rimborsi per i servizi utilizzati con addebito sul credito precaricato
  • Rilascio della ricevuta o del riepilogo delle ultime 30 operazioni
  • Conteggio e verifica della cassa all'apertura e chiusura delle sessioni
  • Assegnazione PC
    Il programma può assegnare o prenotare l'uso dei PC degli utenti registrando il periodo di utilizzazione
    Il controllo automatico dei PC degli utenti da parte del programma
  • Visitatori occasionali
    Ad un Visitatore occasionale si può assegnare provvisoriamente, registrando i suoi dati, una "Tessera Visitatori" con la quale potrà accedere ai servizi della Biblio-Mediateca
  • Lettore di codici a barre
    Il programma può utilizzare un lettore di codice a barre (codifica 3 of 9) collegato ad una porta seriale del PC per acquisire il codice della tessera da gestire
  • Rete
    Il programma può operare su più macchine in rete locale di cui una agirà come Master e le altre come Slaves (per la gestione economica, di sicurezza e di assegnazione macchine)
  • Reports ed Utilities
    Al programma è associato, in un modulo separato, il programma WillerUtilities che permette di analizzare e stampare gli archivi, di creare copie di backup degli stessi e di creare un Listino Comune da distribuire a più impianti.

Dalla versione 5.2 :

  • Criptatura dei dati sensibili
    I dati sensibili (foto, nome, indirizzo, codice fiscale ecc.) dell'utente di una tessera sono automaticamente, e trasparentemente, criptati per aumentare la protezione dei dati personali.
    La chiave di criptazione è diversa da tessera a tessera ed è basata sui parametri della licenza. (La versione DEMO non è criptata)
    Se l'archivio esistente non era già criptato al primo avvio di Willer
verrà emesso un messaggio per richiedere l'autorizzare alla criptatura dei dati
ed un altro per indicare il completamento della procedura.
In mancanza di tale autorizzazione il programma terminerà senza accedere ai dati.

Gli archivi criptati non saranno più compatibili con le precedenti versioni di Willer e dei programmi ausiliarii.
La nuova versione dei programmi ausiliarii (WillerUtilities e WillerPolizia)
è in grado di esaminare sia gli archivi criptati che quelli non criptati.

Tessera di accesso ai Servizi

L'emissione della Tessera utente è il primo atto necessario per accedere ai servizi della Biblioteca Multimediale.
Con WILLER l'operazione è molto semplice: basta una web cam, una telecamera o uno scanner ed in pochi secondi la tessera è pronta.
La cattura dell'area utile per la stampa si effettua con un solo click del mouse e la stampa può essere effettuata con qualsiasi stampante a colori.
Il formato della tessera è quello delle carte di credito e sul lato recto riporta, oltre alla foto dell'utente, nome e cognome e numero di iscrizione anche in barcode (in codice 3 of 9).
Questi elementi: foto, cognome, nome e numero, obbligatori per stampare la tessera non potranno più essere modificati a differenza degli altri dati anagrafici che potranno essere immessi o modificati anche in seguito.
E' presente uno spazio per il logo del Comune e della Biblioteca (obbligatorio anch'esso).

Nota: è possibile creare una tessera senza avere la foto a disposizione, la foto sarà possibile inserirla in un secondo momento e, contestualmente, procedere alla stampa della tessera (vedi creazione tessera)

Sul verso è possibile inserire con facilità qualunque immagine promozionale o di sponsor.
A richiesta può essere fornito un kit modulare composto da: web cam, stampante a getto d'inchiostro, plastificatore a caldo, pistola per lettura bar code.
Anche i materiali di consumo (pochettes di plastificazione, cartoncino, inchiostri) sono forniti su richiesta.

Pagamenti

WILLER semplifica il problema del maneggio di denaro col sistema del "pre-pagamento immediato".
L'utente deve, al momento della richiesta di servizi a pagamento, caricare la disponibilità nel suo conto personale. L'importo della ricarica minima è fissato dal regolamento ed il versamento deve essere fatto preferibilmente in banconote.
Il software provvede a calcolare l'importo sottraendolo al residuo caricato nella tessera.
Ogni transazione è, a richiesta, accompagnata dalla ricevuta.
Il software memorizza comunque un riassunto delle ultime 30 operazioni di ogni utente che può essere stampato a richiesta.
Le transazioni degli utenti occasionali che non desiderano iscriversi alla Biblioteca possono essere gestite mediante apposite Tessere "visitors" secondo modalità identiche agli altri utenti.

Sicurezza

Ogni operatore si abilita attraverso una password assegnata dall'amministratore.
All'inizio ed alla chiusura di ogni sessione/operatore viene effettuata la verifica della somma presente in cassa.
Il sistema della pre-carica istantanea del credito sulla tessera elimina di fatto i problemi di conteggio e dei resti.
E' sempre possibile richiedere il rimborso delle somme inutilizzate.

Controllo automatico dei PC degli utenti

(solo se Willer viene installato su una macchina con sistema operativo Windows 2000 o superiore; su una macchina Windows 98 la funzionalità di controllo automatico verrà disattivata ed alcune delle specifiche decritte più avanti verranno modificate non essendo applicabili)
Questo controllo automatico permette di gestire l'accesso alle macchine della Biblio-Mediateca consentendolo solo dopo aver identificato l'utente (tramite la sua Tessera o i dati personali nel caso di un visitatore occasionale) e registrando in un archivio protetto l'evento di inizio e fine uso come richiesto dal recente decreto Pisanu.
Essendo tutti i dati identificativi dell'utente, compresa la sua foto, presenti in archivio tale identificazione può avvenire anche quando l'utente abbia dimenticato la sua tessera ricercandolo nell'archivio tramite il suo Nome e/o Cognome e confrontando l'utente con la foto visualizzata.

Gestione delle tariffe o Listino prezzi

Il Listino Prezzi è organizzato in sezioni:

  • Una sezione Comune che conterrà le Voci comuni a più Istituzioni (Biblioteche ecc.) e sarà creata e modificata, possibilmente, da una istituzione Capofila per la distribuzione alle altre.
    Lo scopo di tale sezione è quello di avere delle Voci di riferimento comuni per la generazione di statistiche.

  • Una sezione Locale che conterrà le Voci di interesse locale e sarà creata e modificata direttamente con questo programma.
Ai fini della gestione economica le diverse sezioni saranno considerate come un unico listino.

L'inserimento delle voci di spesa è personalizzabile (per es. tessera annuale, connessione internet, stampe, copia su floppy, o CD Rom, uso stazioni editing video-grafiche ecc.), è molto semplice e può riportare nella stampa il provvedimento di adozione delle tariffe o della validità del listino.


Willer - Pagine manuale

Manuale di Willer versione 5.1

Elenco delle pagine:

Installazione
Installazione di Willer
Registrazione del programma
Inizializzazione degli archivi
Operatori e password di default

Installazione del controllo automatico sulle macchine utenti
Note generali
Prerequisiti per Windows 98
Prerequisiti per Windows 2000 e XP
Procedura di installazione

Manuale di uso
Avvio e Chiusura
Avvio su macchina Willer tipo Master (o singola)
Avvio su macchina Willer tipo Client
Chiusura su macchina Willer tipo Master (o singola)

Schermata principale

Creazione nuova tessera
passo 1 : Anagrafe dell'utente
passo 2 : Fotografia dell'utente
passo 3 : Stampa ed archiviazione della tessera

Gestione di una tessera
Selezione della tessera
Dati anagrafici
Dati avanzati
Assegnazione PC
Duplicato tessera
Visitatori occasionali

Gestione economica
Versamenti ed acquisti
Gestione della Cassa

Definizioni
Modifiche agli Operatori
Profili di utenti
Macchine associate
Listino prezzi locale

Controllo automatico delle macchine utenti

WillerUtilities
Rapporto giornaliero
Statistiche economiche
Statistiche sicurezza
Statistiche Tessere
Gestione listino Comune
Backup degli archivi
Ripristino degli archivi

Appendice
Localizzazione archivi
Conversione vecchi archivi
Stampante per ricevute
Eventi di sicurezza
Struttura del file ini
Errori e rimedi


Willer - Pagine installazione

Procedure di installazione

Elenco delle pagine:

Installazione di Willer
Registrazione del programma
Inizializzazione degli archivi
Operatori e password di default

Installazione del controllo automatico sulle macchine utenti
Note generali
Prerequisiti per Windows 98
Prerequisiti per Windows 2000 e XP
Procedura di installazione


Willer - Note Installazione

Willer - Note sulla prima installazione
Queste cautele si applicano se si attiva l'opzione di gestione in automatico delle macchine utenti ed esistono più utenti abilitati all'uso della macchina.

Sarà opportuno che il programma sia "visibile" solo accedendo alla macchina con un username specifico (p.es. WillerGest) che goda dei privilegi di amministratore (come di solito avviene nell'installazione di un programma).

Si ricordi che l'installazione, l'eventuale rimozione e reinstallazioni successive DOVRANNO SEMPRE essere eseguite dallo stesso utente (username) del sistema operativo.
Tale utente dovrà avere i privilegi di Amministratore.

Qualora si tenti una rimozione e/o reinstallazione con un altro utente (username), anche se tale utente gode dei privilegi di Amministratore, sorgeranno problemi con le operazioni nel Registro perchè talune Chiavi avranno assegnato come proprietario il primo utente utilizzato e non potranno essere modificate da nessun altro utente !
In caso di problemi bisognerà quindi intervenire sul Registro per modificare il proprietario delle suddette Chiavi, cancellarle e quindi procedere alla reinstallazione completa del programma.

Per il programma Willer la fase di Prima Installazione verrà completata dopo l'inizializzazione degli archivi, al termine della Registrazione ed avvio del programma, e SOLO qualora sia stata resa attiva l'opzione di gestione in automatico delle macchine utenti; solo in tale momento avverrà l'effettiva installazione del sistema di controllo che interverrà sul Registro come sopra indicato.
Se sulla stessa macchina si è già installata (completamente) la versione DEMO e si introduce la licenza il sistema di controllo NON verrà reinstallato.


Registrazione Willer

Registrazione del programma

Per attivare il programma alla funzionalità richiesta inserire i dati come pervenuti nella licenza.

Sono disponibili licenze per i seguenti livelli di funzionalità:

Livello 1 = Creazione e stampa delle tessere, gestione anagrafica ed avanzata, gestione operatori.
Livello 2 = Come livello 1 e, in più, la gestione economica della singola tessera.
Livello 3 = Come livello 2 e, in più, la gestione di sicurezza ed il controllo automatico di 20 PC associati.
Livello 4 = Come livello 2 e, in più, la gestione di sicurezza ed il controllo automatico di 40 PC associati.
Livello 5 = Come livello 2 e, in più, la gestione di sicurezza ed il controllo automatico di 60 PC associati.

La modalità DEMO è impostata al livello più alto disponibile con alcune limitazioni rispetto a quella Registrata:

Modalità | DEMO | Registrata
massimo numero di tessere gestibili | 25 | illimitato
massimo numero di Categorie economiche sul Listino Comune | 0 | 40
massimo numero di Categorie economiche sul Listino Locale | 5 | 40
massimo numero di voci in ciascuna Categoria | 5 | 99
massimo numero di PC controllabili | 5 | 20, 40 o 60

Il passaggio da modalità DEMO a quella Registrata comporta la generazione ex-novo di tutte le informazioni come se il programma fosse stato appena installato.


Avvio Willer

Inizializzazione archivi

Per trasferire gli archivi da versioni precedenti consultare prima la voce: Conversione Archivi

Per iniziare bisogna fornire le seguenti informazioni (vedi anche localizzazione archivi):

  • Parametri di base
  • Opzioni di emissione delle Tessere
  • Opzioni di controllo remoto delle Macchine
  • Registrazione ed avvio del programma

Parametri di base

Questa macchina è l'unica dedicata alla gestione del sistema (default: si)
Indica se la macchina collabora con altre (Master/Slave) per la gestione delle Tessere o se è l'unica macchina dedicata.
Se essa è l'unica alcune modalità di sincronizzazione tra le macchine verranno disattivate ed il suo funzionamento sarà più veloce.

Posizione dell'Archivio di Willer (vedi posizione nella rete)
Ricercare o creare nella rete locale la cartella nella quale sarà conservato l'archivio del programma (tessere, utenti, listini ecc.).

Posizione dell'archivio delle cartelle associate alle Tessere (vedi posizione nella rete)
Ricercare o creare nella rete locale la cartella nella quale saranno conservati i documenti associati a ciascuna tessera.
Per ogni tessera creata sarà possibile generare una cartella, come sottocartella di quella qui definita, con il nome uguale al codice della tessera e nella quale l'operatore potrà inserire qualsivoglia file da conservare con riferimento a quella tessera.

Verificare la scadenza di una tessera solo quando vi si accede (default: si)
Indica se la verifica delle eventuali tessere scadute, disabilitate ecc. verrà effettuata solo quando si accede a quella tessera o su tutte le tessere ad ogni avvio del programma.
Se si sceglie questa modalità il processo di avvio del programma sarà più veloce.

Ritorna all'inizio pagina

Opzioni di emissione Tessere

(Si applicano solo al PC autorizzato ad emettere le Tessere.)

Questa macchina può emettere le Tessere o modificare i Listini (default: no)
(L'opzione verrà comunque forzata a vera se la macchina è l'unica dedicata alla gestione)
E' un CheckBox che serve a stabilire se una macchina opererà come Master (detta anche Server) o come Slave (detta anche Client).

Willer , dalla versione 2.x, è in grado di funzionare in una rete locale con più operatori contemporanei.

Le macchine della rete condividono gli stessi archivi (tessere, economico e listini) ma con funzionalità differenti:

Slaves (Clients) | possono agire sulle singole tessere presenti in archivio: dati, profili, gestione economica per la parte relativa agli acquisti (se vi è disponibilità), assegnazione e controllo delle macchine date in gestione a tali slaves e la presa in carico delle stesse in base ai privilegi dell'operatore.
Master (Server) | è anche autorizzata ad emettere nuove tessere, gestire i movimenti di cassa (entrate ed uscite), stampare duplicati e a modificare i listini, definire i profili di utenti e le macchine da controllare in base ai privilegi dell'operatore;

Si consiglia di assegnare la funzionalità Master ad una ed una sola macchina per una corretta gestione degli accessi ai database !

I parametri seguenti si applicano solo alla macchina Master (Server); sulle macchine Slave (Client) non è necessario specificarli perchè esse non possono creare nuove tessere.

Numero di caratteri della Tessera (da 6 a 10) (default: 10)
E' il numero di caratteri alfanumerici di cui sarà composto il codice di tutte le Tessere create.

Codifica libera delle Tessere (default: no)
Selezionando questa opzione verrà disabilitata la codifica automatica.
E' un CheckBox con il quale si predispone l'archivio ad accettare il Codice della singola Tessera introdotto manualmente dall'operatore ad ogni creazione.
Il codice libero così creato può essere composto da qualsiasi combinazione di lettere e cifre.
Il sistema verificherà che esso sia accettabile e che non sia ripetuto nell'archivio.

Codifica Automatica delle Tessere (attivo di default)
Il codice di ogni nuova Tessera verrà generato in modo automatico in base alle regole indicate:

    • Formato della tessera
    E' un insieme di caratteri e numeri (da 0 a 5 max) che servirà per identificare ciascuna tessera come appartenente all'impianto.
    Il sistema può gestire fino a 1.999.999.999 di tessere come potenzialità teorica. Si tenga però presente che ciascuna tessera occuperà circa 40 KBytes pertanto un limite pratico ragionevole è di circa 100.000 tessere (corrispondente ad un archivio di circa 4 GBytes).
    Introducendo un header si limita il sistema ad un numero inferiore di tessere ciascuna marcata con un prefisso costante.
    (Nell'esempio che segue si fa riferimento ad un codice di 10 caratteri):

    Caratteri header | Tessere gestibili |  | Header | Prima tessera | Ultima tessera
0 | 1999999999 |  | nessuno | 0000000001 | 1999999999
1 | 999999999 |  | E | E000000001 | E999999999
2 | 99999999 |  | EL | EL00000001 | EL99999999
3 | 9999999 | Esempio: | ELV | ELV0000001 | ELV9999999
4 | 999999 |  | ELVI | ELVI000001 | ELVI999999
5 | 99999 |  | ELVIS | ELVIS00001 | ELVIS99999

    Il formato della Tessera può specificare sia un prefisso che un suffisso da utilizzare per ogni Tessera creata.
    Se, come in figura, si inserisce un "*" nella voce la tessera verrà creata sostituendo questo carattere con un numero progressivo.
    Assumendo un codice di 10 caratteri ed una parte fissa di 5 si ha:

    Posizione dell' * | Esempio | Formato della Tessera n. 1234
nessuno | ELVIS | ELVIS 01234
1 | *ELVIS | 01234 ELVIS
2 | E*LVIS | E 01234 LVIS
3 | EL*VIS | EL 01234 VIS
4 | ELV*IS | ELV 01234 IS
5 | ELVI*S | ELVI 01234 S
6 | ELVIS* | ELVIS 01234

    Si noti che inserire l' * in fondo è equivalente a non metterlo.
    Il totale dei caratteri fissi specificabili, escluso l'eventuale *, rimane fissato ad un massimo di 5 !

    • Numero della prima tessera da emettere (Non modificabile nella versione DEMO)
    E' possibile indicare il numero della prima tessera da emettere per riservarne alcuni all'inserimento manuale di tessere già esistenti.
    Il valore da immettere è compreso tra 1 e 9999 (se minore o uguale a 0 viene forzato a 1 per default).
    Nota: Il numero della successiva tessera da emettere è automaticamente controllato ed allineato ad ogni avvio del programma per garantire che esso sia superiore a quello delle tessere già emesse.

    Non stampare gli zeri iniziali
    E' un CheckBox con il quale si istruisce il programma a non stampare sulla Tessera eventuali zeri iniziali del codice della tessera (sia in chiaro che nel codice a barre).
    Il codice della tessera verrà stampato a partire dal primo carattere diverso da "0".

    Non stampare il Codice a Barre
    E' un CheckBox con il quale si istruisce il programma a non stampare sulla Tessera il codice in modalità Codice a Barre (3 of 9) per applicazioni particolari.
    Il campo verrà lasciato bianco.

    Ritorna all'inizio pagina

    Opzioni di controllo remoto delle Macchine

    Parametro principale : | tipo / range | valore di default
Questa macchina gestisce in automatico le macchine utenti (Abilitabile solo se il sistema operativo è Windows 2000 o superiore) Attiva il controllo automatico da parte di Willer delle macchine utenti gestibili da questa macchina. Nuovo nella versione 5 : Se non viene abilitato le macchine utenti saranno gestibili solo in modalità manuale per l'assegnazione e la prenotazione. | CheckBox | disabilitato
Altri parametri : |  |
Nome di servizio di questa macchina | testo | ElvisControl
Inviare il messaggio di presenza ogni ... secondi | 5...30 | 15
Numero della porta UDP di presenza | 1200...65534 | 23122
Numero della porta UDP di servizio (diversa dalla precedente) | 1201...65535 | 23123
Criptare le comunicazioni | CheckBox | disabilitato
Nome eventuale Dominio di accesso | nome dominio |
File Log degli errori | nome file | C:\Programmi\Willer\ErrorLog.txt
Password di accesso Visitatori: nessuna | CheckBox | disabilitato
Password di accesso Utenti: facoltativa | CheckBox | disabilitato

    Modificare solo il parametro principale per attivare il controllo, il valore di default degli "altri parametri" è di solito corretto nel caso di una installazione singola mentre per installazioni più complesse è opportuno rivolgersi alla Elvis per concordare i migliori valori da utilizzare tenendo conto di altre funzionalità presenti nella rete locale.

    Le voci Password di accesso consentono di modificare la politica di accesso alle macchine utenti:
    Se si abilita la voce Visitatori : nessuna i visitatori riceveranno l'accesso alla macchina assegnata senza dove digitare nessuna password;
    analogamente se si abilita la voce Utenti : facoltativa l'accesso avverrà senza password a meno che l'utente abbia esplicitamente richiesto di utilizzare una password nella programmazione avanzata della sua Tessera.
    Se le voci sono disabilitate si applica la regola indicata nell'assegnazione di una macchina.

    Per default l'accesso alle macchine gestite viene effettuato con una autorizzazione "locale", cioè sulla singola macchina controllata da Willer (purché l'utente sia stato creato ed autorizzato su tale macchina).

    Se si intende autenticare le macchine gestite in un Dominio (di tipo Windows 200x Server p.es.) è necessario specificare alla voce Nome eventuale Dominio di accesso il nome del suddetto Dominio ed utilizzare una speciale sintassi nella definizione dell'username di accesso nelle voci Nome Utente Windows e UserName della Manutenzione

    • Se si desidera che lo stesso username del dominio sia usato per tutte le macchine gestite (cioè tutte le macchine utilizzano lo stesso profilo utente del dominio e condivideranno, perciò, le stesse risorse programmate) usare come ULTIMO carattere dell'username di accesso (in Nome Utente Windows o in UserName della Manutenzione) il carattere: @ (esempio: pippo@ )

    • Se si desidera che ciascuna macchina gestita acceda al dominio con un username diverso (cioè ogni macchina utilizza un diverso profilo utente del dominio e differenti risorse programmate) usare come ULTIMO carattere dell'username di accesso (in Nome Utente Windows o in UserName della Manutenzione) il carattere: # (esempio: pippo# )

    • Se si desidera che l'accesso alle macchine avvenga in modo "locale", cioè senza la convalida da parte del dominio, ma con un nome differente per ciascuna macchina, (per esempio per accedere ad un server con profili differenti da macchina a macchina) usare come ULTIMO carattere dell'username di accesso (in Nome Utente Windows o in UserName della Manutenzione) il carattere: ! (esempio: pippo! )

    • Se, infine, si desidera che l'accesso alle macchine avvenga in modo "locale", cioè senza la convalida da parte del dominio, e con lo stesso nome per tutte le macchine, NON utilizzare nell'username di accesso (in Nome Utente Windows o in UserName della Manutenzione) nessuno dei caratteri predetti. (esempio: pippo, non pippo@ oppure pippo# o, ancora, pippo!)

    N.B.: la funzionalità di accesso a domini differenti dal predefinito esistente nelle versioni precedenti la 4.3 è stata abolita.

    Non utilizzare i caratteri @ # ! in altre parti dell'username !

    Il sistema provvederà comunque ad eliminare i caratteri diversi dalle lettere alfabetiche o numeri dal testo inserito, escluso l'eventuale ultimo carattere, pertanto digitando come utente Windows "Gianni A. De' Pisis@" il nome verrà automaticamente convertito in "GianniADePisis@" sopprimendo i caratteri non alfanumerici e gli spazi introdotti e conservando l'eventuale ultimo carattere speciale.

    Modificato nella versione 5
    Se la voce Nome eventuale Dominio di accesso non è presente l'autenticazione verrà tentata sulla macchina locale
    considerando il carattere @ come se non ci fosse ed il carattere # come se fosse il carattere !.

    Ovviamente la password di accesso è unica e, quindi, unica deve essere nelle macchine gestite o nei corrispondenti profili creati nel dominio.

    Esempio:
    Avendo un dominio di nome Biblioteca.local dichiarato in fase di installazione ed una macchina gestita il cui nome di gestione (non il suo nome di rete !) sia pcRagazzi l'utente con username Utente e password Pass1234 accederà alla macchina suddetta come:

    • Utente@Biblioteca.local se la dichiarazione è: Utente@

      purchè nel dominio Biblioteca.local esista e sia autorizzato il profilo:
      username: Utente
      password: Pass1234

    • Utente.pcRagazzi@Biblioteca.local se la dichiarazione è: Utente#

      purchè nel dominio Biblioteca.local esista e sia autorizzato il profilo:
      username: Utente.pcRagazzi
      password: Pass1234

    • Utente.pcRagazzi senza accesso al dominio Biblioteca.local se la dichiarazione è: Utente!

      purchè nella macchina pcRagazzi esista e sia autorizzato il profilo locale:
      username: Utente.pcRagazzi
      password: Pass1234

    • Utente senza accesso al dominio Biblioteca.local se la dichiarazione è: Utente

      purchè nella macchina pcRagazzi esista e sia autorizzato il profilo locale:
      username: Utente
      password: Pass1234

    Ritorna all'inizio pagina

    Registrazione ed avvio del programma

    Se si opera sulla macchina Master premendo il tasto Conferma si visualizzerà la maschera seguente:

    e premendo il tasto OK verrà richiesta una speciale password numerica dipendente dalla licenza:

    e, se corretta, si inizializzerà l'archivio delle tessere altrimenti il programma verrà termiato.

    Nota: per la versione demo o se la creazione è contestuale all'immissione della licenza la password non verrà richiesta.

    Analogamente avverrà per la creazione dell'archivio economico con la maschera:

    E, per il livello 3 o successivo, per la creazione dell'archivio di sicurezza, dei visitatori e, se attivata, la prima installazione del sistema di controllo delle macchine utenti.

    Se si opera su una macchina Slave e l'archivio tessere, economico, di sicurezza o dei visitatori non esiste già si genererà un errore ed il programma verrà terminato.

    Ritorna all'inizio pagina


Default Willer

Operatori e Passwords di default

Modificato nella versione 5

Al primo avvio del programma vengono creati i 10 operatori come di seguito riportato :

N. Operatore | Abilitato | Privilegiato | Nome (Nickname) | Password
Principale | SEMPRE | SEMPRE | sys | 1234
1 | NO | NO | usr1 | 1111
2 | NO | NO | usr2 | 2222
3 | NO | NO | usr3 | 3333
4 | NO | NO | usr4 | 4444
5 | NO | NO | usr5 | 5555
6 | NO | NO | usr6 | 6666
7 | NO | NO | usr7 | 7777
8 | NO | NO | usr8 | 8888
9 | NO | NO | usr9 | 9999

Eventuali modifiche sono possibili dopo l'installazione con la voce Gestione degli Operatori e delle Password

Modificato nella versione 5

L'operatore principale è l'unico autorizzato ad assegnare le abilitazioni ed i privilegi nonché a modificare le passwords degli altri operatori

L'operatore principale, e gli operatori da lui designati come privilegiati, sono i soli autorizzati alle seguenti operazioni:

  • Modificare il codice di licenza dell'impianto

  • Modificare il testo stampato sulle ricevute (solo sulla macchina Master)

  • Modificare il listino prezzi locale della gestione economica (solo sulla macchina Master)

  • Modificare i profili degli utenti (solo sulla macchina Master)

  • Modificare la lista delle macchine gestite in automatico o in manuale

  • Mettere una macchina (gestita dal controllo automatico) in Manutenzione

  • Programmare il tempo di Preavviso agli Utenti di una macchina gestita dal controllo automatico

  • Utilizzare WillerUtilities per il ripristino o la gestione del listino comune


ElvisControl - Installazione

Note per l'installazione sulle macchine utenti
Si ricordi che l'installazione, l'eventuale rimozione e reinstallazioni successive DOVRANNO SEMPRE essere eseguite dallo stesso utente del sistema operativo.
Tale utente dovrà avere i privilegi di Amministratore del PC.

Si consiglia di utilizzare l'utente che verrà anche usato per la manutenzione (ovviamente assegnandogli i privilegi di Amministratore !).

Qualora si tenti una rimozione e/o reinstallazione con un altro utente (username), anche se tale utente gode dei privilegi di Amministratore, sorgeranno problemi con le operazioni nel Registro perchè talune Chiavi avranno assegnato come proprietario il primo utente utilizzato !
In caso di problemi bisognerà quindi intervenire sul Registro per modificare il proprietario delle suddette Chiavi, cancellarle e quindi procedere ad una nuova installazione !


ElvisControl - Generalità

Controllo automatico - Generalità

Il sistema di controllo automatico delle macchine associate incorporato in Willer richiede che su ciascuna macchina associata (di seguito detta macchina Client) sia installato un programma (RemoteClient.exe) in grado di dialogare via rete con Willer.

Per poter colloquiare il sistema Willer e la macchina Client devono condividere le informazioni indicate con le freccie nella figura sottostante:

Esse sono suddivise in tre gruppi :

  • In rosso

    I parametri che dovranno essere modificati su ciascuna macchina Client e resi coincidenti con quelli dichiarati su Willer :

    • Nome della Macchina che deve essere coincidente ed unico per l'intero sistema.
      Questo nome è un "nome di fantasia" non essendo necessario che coincida con il nome di rete della macchina stessa.
      Note:
      1. Esso dovrà anche essere diverso dal nome assegnato a Willer come gestore del sistema di controllo automatico (ElvisControl nell'esempio);
      2. Alcune parti del programma non distinguono tra maiuscole e minuscole, altre si pertanto si mantenga l'esatta corrispondenza dei nomi anche a livello di maiuscole e minuscole.

    • Controllo Remoto attivato che deve essere attivato sia sul Client che su Willer nella fase di primo avvio.

  • In verde

    I numeri di porta UDP con i quali comunicare; i valori di default sono normalmente adatti e non è necessario modificarli.

  • In giallo

    I parametri opzionali che potranno essere modificati su ciascuna macchina Client e resi coincidenti con quelli dichiarati su Willer :

    • Criptare i messaggi trasmessi che deve essere attivato sia sul Client che su Willer nella fase di primo avvio.
      Se su una macchina Client (come nel caso di sistema operativo Windows 98) l'opzione non è attiva le comunicazioni tra tale Client e Willer avverrano senza criptazione; lo stesso avverrà se l'opzione non è attivata su Willer indipendentemente dalla programmazione del Client.

    • Chiave di criptazione che deve essere dichiarata uguale sia sul Client che su Willer.
      Essa può essere differente da Client a Client e verrà usata solo se la voce precedente consente di stabilire delle comunicazioni criptate.

Un'ulteriore opzione è indicata in blu: Al Logout dell'Utente eseguire il Riavvio del PC ed è disponibile per usi particolari come programmi che ripristinino lo stato della macchina al riavvio per consetirne l'esecuzione ad ogni cambio utente.

Il parametro [image] definisce il tempo lasciato all'utente per chiudere il lavoro nel caso di invio da parte di Willer dei comandi Spegni la Macchina e Liberare la macchina, è indipendente da quello di preavviso per fine lavori ed è di default impostato a 120 secondi ma può essere ridotto se si ritiene opportuno.

Gli altri parametri del Client e di Willer non sono in diretta connessione ma, comunque, devono essere ragionevoli per evitare problemi di perdita delle connessioni od altro. Si consiglia di lasciare i valori di default.


ElvisControl - Prerequisiti per Windows 98

Controllo automatico - Prerequisiti per Windows 98

Per poter installare correttamente in programma di controllo remoto RemoteClient su una macchina con sistema operativo Windows 98 è necessario attuare i seguenti passi preliminari:

  • Configurazione della rete

  • Configurazione degli utenti

  • Tweak UI e verifiche

Si ricordi che TUTTI gli utenti della macchina DOVRANNO essere dotati di password !

Configurazione della rete

Seguire i passi indicati per configurare la modalità di accesso a Windows 98 necessaria.
La rete deve essere configurata con indirizzo Tcp/Ip statico facente parte della rete locale, un opportuno nome di rete ecc. ecc.

1. Aprire il Pannello di Controllo e selezionare la voce Rete
2. Scegliere il tasto Aggiungi
3. Scegliere la voce Client e premere il tasto Aggiungi
4. Scegliere a sinistra la voce Microsoft e a destra la voce Accesso di gruppo personalizzato indi premere il tasto OK
5. Dalla lista Accesso primario scegliere la voce Accesso di gruppo personalizzato
6. Confermare le modifiche con il tasto OK rifiutando una eventuale richiesta di riavvio della macchina.

Ritorna all'inizio pagina

Configurazione degli utenti

Sulla macchina dovranno essere definiti TUTTI gli utenti che potranno accedervi secondo quando programmato in Willer alle voci Definizioni Utenti e Macchine Associate.
In particolare si presti attenzione alla necessità di definire l'utente Generico e quello di Manutenzione.

Seguire i passi indicati per creare ciascuno degli utenti.

1. Aprire il Pannello di Controllo e selezionare la voce Utenti
2a. Se è il primo utente creato selezionare Avanti
2b. Se sono già stati creati degli utenti selezionare la voce Nuovo Utente
3. Digitare il nome del nuovo utente corrispondente ad uno definito nei profili utente di Willer alla voce Nome Utente Windows e premere Avanti
4. Inserire la password dell'utente corrispondente ad quella definita nei profili utente di Willer alla voce Password di accesso e premere Avanti
5. Selezionare le opzioni più opportune per definire questo utente e premere Avanti
6. Per completare premere Fine rifiutando una eventuale richiesta di riavvio della macchina.

Ripetere i passi precedenti fino a configurare tutti gli utenti necessari, compreso l'utente che si occuperà della manutenzione e che dovrà avere i privilegi di un amministratore e poter accedere a tutte le funzionalità.

Tweak UI e verifiche

Infine se nella macchina fosse stato utilizzato il programma Tweak UI si presti attenzione a disattivare l'accesso automatico.

Verificare, riavviando la macchina, che tali opzioni siano state accettate.
Dovrà comparire una finestra di login come la seguente:

Ritorna all'inizio pagina


ElvisControl - Prerequisiti per Windows 2000 e XP

Controllo automatico - Prerequisiti per Windows 2000 e XP

Per poter installare correttamente in programma di controllo remoto RemoteClient su una macchina con sistema operativo Windows 2000 o Windows XP è necessario attuare i seguenti passi preliminari:

  • Configurazione di Login per Windows 2000

  • Configurazione di Login per Windows XP

  • Configurazione degli utenti

  • Verifiche

Si ricordi che TUTTI gli utenti della macchina DOVRANNO essere dotati di password !

Configurazione di Login per Windows 2000

E' necessario disattivare l'opzione che richiede di premere i tasti Ctrl Alt Canc per inserire l'utente e la password.

1. Accedere, come amministratore, alla voce Strumenti di Amministrazione del Pannello di Controllo
2. Selezionare la voce Opzioni di protezione locali
2. Aprire la voce Consente di arrestare il sistema senza effettuare l'accesso ed attivarla
3. Aprire la voce Disabilita requisito di accesso CTRL+ALT+CANC ed attivarla

Ritorna all'inizio pagina

Configurazione di Login per Windows XP

E' necessario disattivare l'opzione che consente il cambio rapido degli utenti, oltre che, se attiva, quella che richiede i tasti CTRL+ALT+CANC come in Windows 2000.

1. Accedere, come amministratore, alla voce Account Utente del Pannello di Controllo e selezionare Cambia modalità di accesso e disconnessione
2a. Lasciare attivata la voce Usa schermata iniziale ma disattivare Utilizza cambio rapido utente
o, meglio :
2b. Disattivare la voce Usa schermata iniziale

Ritorna all'inizio pagina

Configurazione degli utenti

Sulla macchina dovranno essere definiti TUTTI gli utenti che potranno accedervi secondo quando programmato in Willer alle voci Definizioni Utenti e Macchine Associate.
In particolare si presti attenzione alla necessità di definire l'utente Generico e quello di Manutenzione.

1. Accedere, come amministratore, alla voce Gestione del Computer / Users negli Strumenti di Amministrazione del Pannello di Controllo
2. Digitare il nome del nuovo utente corrispondente ad uno definito nei profili utente di Willer alla voce Nome Utente Windows, inserire la password dell'utente corrispondente ad quella definita alla voce Password di accesso, scegliere la voce Nessuna scadenza password ed infine premere Crea

Ripetere il punto 2 fino a creare tutti gli utenti necessari.
Configurare per tutti gli utenti creati il profilo di accesso ed i privilegi, compreso l'utente che si occuperà della manutenzione e che dovrà avere i privilegi di un amministratore e poter accedere a tutte le funzionalità.

Ritorna all'inizio pagina

Verifiche

Verificare, riavviando la macchina, che tali opzioni siano state accettate.
Dovrà comparire una finestra di login simile alla seguente:

Ritorna all'inizio pagina


ElvisControl - Installazione

Installazione del Controllo automatico

Per installare il controllo automatico sulle macchine Client seguire i seguenti passi:

Nella macchina sulla quale è installato Willer accedere alla directory di Willer (tipicamente C:\Programmi\Willer).
Si evidenziano due sottocartelle:
  • ClientControl
  • ClientService

Copiare queste cartelle su un supporto mobile (tipo floppy o penna USB).

Su ciascuna macchina Client:

1. Copiare dal supporto mobile la cartella ClientControl in una posizione accessibile solo all'amministratore della macchina, (p. es. C:\Windows\System).

Aprendo la cartella appena creata:
(C:\Windows\System\ClientControl)
si vedranno i seguenti files:

2. Aprire la cartella ClientService presente sul supporto mobile e copiare nella cartella creata sopra il file:
InstallaClient.bat

3. A questo punto aprire la cartella:
(C:\Windows\System\ClientControl)
e lanciare (fare "doppio click") il file InstallaClient.bat.

4. Il controllo remoto verrà ora installato.
Una volta completata l'installazione cancellare il file InstallaClient.bat sopradetto per evitare errori di doppia installazione !

5. Dalla cartella ClientService (presente sul floppy o sulla penna USB) lanciare il programma:
ConfigurationManager.exe.

Programmare i punti indicati con 1, 2 e 3 secondo quanto indicato nella pagina delle generalità.

Attenzione: il punto 2 va attivato SOLO quando si vorrà effettivamente mettere in funzione il controllo automatico !

Confermare il tutto premendo il tasto OK.

Riavviare la macchina per consentire a Willer di prenderne il controllo (se si è attivato il controllo remoto di cui al punto 2 ).

Gli altri parametri mostrati nella finestra possono, di norma, essere lasciati al valore di default.
Il loro significato è (dovrebbe essere) autoesplicativo.

Modificata nella nuova versione del Client
E' presente anche una finestra di "Localizzazione messaggi" nella quale è possibile modificare il testo dei messaggi che verranno mostrati all'utente nelle varie finestre di funzionamento:

nella quale è evidenziata in blu la frase che deve essere digitata per eseguire manualmente lo spegnimento.

Si noti anche che nel Titolo finestra 'Avviso fine lavoro' (che è l'avviso per l'utente che il tempo sta par scadere)
deve rimanere la scritta "{RIMANGONO}" la quale sarà sostituita automaticamente con il tempo (minuti e secondi) rimanente alla scadenza !

Le modifiche si effettuano selezionando la scritta interessata, modificandola nella riga inferiore e registrandola con l'apposito tasto Registra modifica del testo.
Il tasto Ripristina testo originale serve per ripristinare, in quella riga, il testo originale (di fabbrica) come in figura.
Con il tasto Applica o con OK le modifiche diverranno definitive.

Note:

a) Se la macchina viene messa in manutenzione permanente da Willer il controllo remoto viene disattivato, usare il programma ConfigurationManager.exe per riattivarlo (vedi il punto 2).

b) In caso di errori di funzionamento il file ErrorLog.txt (di norma presente nella stessa cartella in cui è stato installato il programma) conterrà una serie di informazioni per la manutenzione.

c) Il file RimuoviClient.bat presente nella cartella ClientService (del floppy o della penna USB) serve a disinstallare il controllo. Se lo si desidera fare bisogna copiare tale file nella cartella (C:\Windows\System\ClientControl), lanciarlo e riavviare la macchina. Ricordarsi di ripetere la procedura di installazione per riprendere il controllo !


Willer - Pagine di uso

Manuale d'uso di Willer

Elenco delle pagine:

Avvio e Chiusura
Avvio su macchina Willer tipo Master (o singola)
Avvio su macchina Willer tipo Client
Chiusura su macchina Willer tipo Master (o singola)

Schermata principale

Creazione nuova tessera
passo 1 : Anagrafe dell'utente
passo 2 : Fotografia dell'utente
passo 3 : Stampa ed archiviazione della tessera

Gestione di una tessera
Selezione della tessera
Dati anagrafici
Dati avanzati
Assegnazione PC
Duplicato tessera
Visitatori occasionali

Gestione economica
Versamenti ed acquisti
Gestione della Cassa

Definizioni
Modifiche agli Operatori
Profili di utenti
Macchine associate
Listino prezzi locale

Controllo automatico delle macchine utenti


Willer - Pagine avvio

Avvio e chiusura di Willer

Elenco delle pagine:

Avvio su macchina Willer tipo Master (o singola)

Avvio su macchina Willer tipo Client

Chiusura su macchina Willer tipo Master (o singola)


Operatore Willer Master

Selezione Operatore

Solo per la macchina Master e licenza di livello 2 o superiore

Nome operatore
E' il "Nickname" dell'operatore che accede al programma (massimo 8 caratteri)

Password
E' la password dell'operatore (massimo 8 caratteri).

N.B.
Per i nomi e le password iniziali fare riferimento alla voce Operatori e Passwords di default

Situazione iniziale di cassa:

Residuo di cassa al ... : viene riportato l'ultimo contenuto della cassa come risulta dall'archivio economico; se esso è dubbio il pulsante Verifica il Residuo di Cassa dal Master Economico permetterà di analizzare tutto l'archivio per ricostruirne il valore.

Contenuto dichiarato della Cassa: indicare l'importo effettivamente presente nella cassa all'inizio delle operazioni per questo operatore.

premendo il tasto Chiudi Programma si abbandonerà il programma mentre premendo il tasto Conferma verrà controllata la validità dei dati immessi e, se corretti, si cambierà l'operatore o si accederà al programma (se è il primo operatore) oppure, se errati, verrà emesso un messaggio di errore e si ritorna alla finestra attuale consentendo di modificare i valori immessi.

Si visualizzerà il seguente messaggio prima di procedere:

rispondendo No si ritorna alla finestra attuale consentendo di modificare i valori immessi.


Operatore Willer Client

Selezione o Cambio Operatore

Solo per le macchine Clients o per licenza di livello 1

Nome operatore
E' il "Nickname" dell'operatore che accede al programma (massimo 8 caratteri)

Password
E' la password dell'operatore (massimo 8 caratteri).

N.B.
Per i nomi e le password iniziali fare riferimento alla voce Operatori e Passwords di default

premendo il tasto Chiudi Programma si abbandonerà il programma, premendo il tasto Annulla si abbandonerà il cambio operatore mentre premendo il tasto Conferma verrà controllata la validità dei dati immessi e, se corretti, si cambierà l'operatore o si accederà al programma (se è il primo operatore) oppure, se errati, verrà emesso un messaggio di errore e si ritorna alla finestra attuale consentendo di modificare i valori immessi.


Chiusura Cassa Willer

Chiusura Operatore o Fine Programma

Solo per la macchina Master e licenza di livello 2 o superiore

Nome operatore
E' il "Nickname" dell'operatore che sta usando il programma

Situazione finale di cassa:

Cassa calcolata: riporta l'importo attualmente presente nella cassa secondo il programma.

Cassa dichiarata: consente di dichiarare l'effettivo ammontare della cassa.

premendo il tasto Annulla si abbandonerà l'operazione di chiusura mentre premendo il tasto Conferma si visualizzerà il seguente messaggio prima di procedere:

rispondendo No si ritorna alla finestra attuale consentendo di modificare i valori immessi.

Confermando, verrà visualizzato il rapporto dei movimenti di cassa effettuati dall'operatore:

che permette di stampare la ricevuta della chiusura di cassa se di interesse.

Se si preme il tasto Annulla l'intera operazione di chiusura sarà annullata, altrimenti si procederà con la chiusura del programma o con la richiesta del nuovo operatore da autorizzare.


Main Willer

Finestra principale di gestione

La finestra principale di gestione è organizzata su quattro parti:

  • Voci di menù
    • Comandi
    • Definizioni
    • Aiuto
  • Tessera in corso
  • Area di gestione
  • Barra di stato
Menù Comandi

con le voci (saranno visibili solo quelle utilizzabili) :

  • Chiusura Operatore (solo per la macchina Master con licenza di livello 2 o superiore)
    (negli altri casi la voce diviene Cambio Operatore )

  • Emetti una nuova Tessera [SOLO SULLA MACCHINA MASTER]
    per generare una nuova tessera (vedi Generazione nuova tessera);

  • Emetti una tessera con il Numero ... [SOLO SULLA MACCHINA MASTER]
    per generare una nuova tessera partendo da un numero fornito dall'operatore: con questo comando è possibile inserire in archivio delle tessere già emesse con altri programmi e conservare nel contempo il loro numero.
    (Non disponibile nella modalità DEMO ed utilizzabile solo dall' operatore privilegiato)

    Verrà richiesto il numero della tessera da inserire:

    che dovrà essere compreso tra 1 ed il numero più grande tra quello iniziale fornito in fase di avvio e quello della tessera più recente inserita in automatico.
    (Questo permette di sostituire eventuali tessere cancellate in precedenza)

    Sarà verificato che la tessera non sia già presente nell'archivio e se la tessera è effettivamente nuova si passerà alla generazione effettiva (vedi Generazione nuova tessera), altrimenti verrà generato un messaggio di errore:

  • Emetti una tessera con il Codice ... [SOLO SULLA MACCHINA MASTER]
    per generare una nuova tessera partendo da un codice fornito dall'operatore.

    Verrà richiesto il codice della tessera da inserire:

    che dovrà rispettare le regole fornite in fase di avvio.

    Modificato nella versione 5 : se il codice inserito ha meno caratteri di quelli indicati nella fase di avvio il programma inserirà automaticamente degli zeri prima del codice fornito.
    P.es. se viene fornito il codice TA234Z e la programmazione richiedeva 10 caratteri il codice diverrà automaticamente 0000TA234Z

    Sarà verificato che la tessera non sia già presente nell'archivio e se la tessera è effettivamente nuova si passerà alla generazione effettiva (vedi Generazione nuova tessera), altrimenti verrà generato un messaggio di errore:

  • Gestione della Cassa (solo per la macchina Master con licenza di livello 2 o superiore)
    che consente di giustificare i prelievi (o i versamenti) di Cassa da parte di un operatore;

  • Deposito in Tesoreria (solo per la macchina Master con licenza di livello 2 o superiore)
    che consente di preparare la ricevuta per il deposito di una parte della Cassa presso l'Ufficio di Tesoreria deputato.
    Verrà richiesta la somma da depositare :

    (il sistema propone la cifra più vicina alla somma attualmente presente in cassa arrotondata ai 10 o 100 euro inferiori)
    e sarà possibile completare l'operazione dando l'OK e stampando la ricevuta:

    contenente tre parti da ritagliare:
    • una da inserire nel plico dei soldi
    • una da far firmare dal responsabile dell'Ufficio come ricevuta
    • una copia per l'Ufficio

  • Stato delle Macchine utenti
    Che consente di accedere allo stato di tutte le macchine utenti:

    in cui selezionare la macchina, inviare ad essa dei comandi, se possibile, ed eventualmente di Spegnere tutte le macchine utenti.

    Si evidenzia in particolare il comando Forza allineamento macchine assegnate che consente, dopo conferma, di correggere problemi, essenzialmente all'avvio del programma, di difficoltà di assegnazione o manutenzione delle macchine.

    Nuovi nella versione 5

    • E' stata aggiunta la possibilità di programmare manualmente (solo dagli operatori privilegiati) il tempo di Preavviso agli Utenti : (da 2 a 10 minuti) per la visualizzazione del tempo rimanente prima della chiusura della macchina.
      Se non si vuole attivare tale opzione selezionare Automatico : il tempo sarà circa 1/10 della durata con un minimo di 2 ed un massimo di 10 minuti.

      NB: Questo tempo non si applica ai comandi Spegni la Macchina e Liberare la Macchina inviati direttamente da Willer, per i quali si applica il tempo [image] definito in fase di installazione del Client.

    • E' disponibile un comando di Sincronia automatica ... con il quale istruire Willer ad inviare alle macchine utenti (a scadenza fissa di 1, 5, 15, 30 o 60 minuti) una sincronizzazione automatica dei loro orologi con quello della macchina Willer. La sincronizzazione avverrà al trentesimo secondo o successivo.
      Se non si vuole attivare tale opzione selezionare: no, solo manuale.

  • Fine Programma che, solo per la macchina Master e licenza di livello 2 o superiore, richiede la fase di chiusura di cassa prima consentire la chiusura del programma

Ritorna all'inizio pagina

Menù Definizioni

con le voci:

  • Operatori
    che consente di definire gli operatori e le relative password;

  • Utenti (solo per la macchina Master)
    che consente solo dall'operatore privilegiato di definire i profili degli utenti;

  • Macchine associate (solo con licenza di livello 3 o superiore)
    che consente solo dall'operatore privilegiato di definire le specifiche dei PC assegnabili agli utenti;

  • Listino prezzi (solo per la macchina Master con licenza di livello 2 o superiore)
    che può essere usata solo dall'operatore privilegiato per definire il listino prezzi locale della gestione economica;

  • Lettore di codici a Barre
    che premette di selezionare su quale porta seriale del PC è collegato il lettore per l'acquisizione della tessera

    (sono elencate le porte da COM1 a COM9 se installate sul PC).

    Nota:

    Se il lettore è installato nell'angolo in basso a sinistra della finestra del programma appare se il lettore è utilizzabile al momento, oppure se il lettore non può essere utilizzato, per esempio quando è presente un messaggio di segnalazione o si sta operando su una delle voci di menù (operatori, utenti, listino ecc.) o ancora se vi è una modifica non ancora registrata

    Azionando il lettore verrà automaticamente selezionata e mostrata la tessera corrispondente se presente in archivio altrimenti verrà emesso un opportuno messaggio di errore.

Ritorna all'inizio pagina

Menù Aiuto

con le voci:

  • Manuale di aiuto (questo manuale);

  • Informazioni
    che visualizza i dati di licenza ecc. e permette, solo all'operatore privilegiato e solo sulla macchina Master, di definire l'intestazione delle ricevute della gestione economica.

  • modifica Licenza
    che può essere usata solo dall'operatore privilegiato per modificare la licenza d'uso;

Ritorna all'inizio pagina

Tessera in corso

Sono visualizzate le principali informazioni relative alla tessera su cui si sta lavorando:

  • Fotografia dell'utente
  • Codice della tessera
  • Profilo utente (permanente o temporaneo) o Stato (disabilitato, scaduto ecc.) della stessa

  • Nome e Cognome dell'utente
e permette di inserire un testo (250 caratteri massimo) che verrà visualizzato ogni qualvolta si accederà a tale tessera.

Ritorna all'inizio pagina

Area di gestione

che permette di selezionare una tessera ed agire sulla stessa per accedere alla gestione economica, modificare i dati anagrafici, quelli avanzati, di assegnare o prenotare una macchina nonchè solo sulla macchina Master di stampare un duplicato della tessera.

E' possibile effettuare la ricerca singolarmente per numero di tessera, per nome o per cognome premendo invio dopo aver inserito il criterio di ricerca nel corrispondente campo (gli altri campi verranno automaticamente azzerati) o usando tutti e tre i campi contemporaneamente con il comando Avvia la ricerca usando tutti i criteri sopraindicati

Sono anche presenti i comandi: Continua la ricerca, Chiudi la tessera corrente e (per gli Slave) Aggiorna tutti gli Archivi che sono utili per consentire la funzionalità alle macchine in rete.

Per limitare la lunghezza dell'elenco delle tessere vengono mostrate solo 100 tessere alla volta, il comando Continua la ricerca permette di passare alle tessere successive.
Quando una tessera è aperta su una macchina essa non è accessibile dalle altre, per questo motivo è presente un comando di chiusura Chiudi la tessera corrente quando essa non viene utilizzata.
Qualora sulla macchina Master vengano inserite nuove tessere o apportate modifiche ai listini o ai profili di utenti il comando di aggiornamento Aggiorna tutti gli Archivi consente alle macchine slave di prelevare le nuove informazioni dall'archivio senza riavviare il programma.

Ritorna all'inizio pagina

Barra di stato

che contiene:
  • una segnalazione che vi sono modifiche non registrate in archivio
  • i comandi per registrare o annullare tali modifiche
  • lo stato attuale della cassa (solo per licenza di livello 2 o superiore)

NB: se ci sono modifiche in corso alcuni comandi sono disattivati per sicurezza dei dati, in particolare non sarà possibile cambiare tessera o operatore o uscire dal programma senza aver prima registrato od annullato le modifiche apportate alla tessera in corso.

Ritorna all'inizio pagina


Willer - Pagine creazione

Creazione nuova tessera

Elenco delle pagine:

passo 1 : Anagrafe dell'utente

passo 2 : Fotografia dell'utente

passo 3 : Stampa ed archiviazione della tessera


New willer - passo 1

Creazione nuova tessera: passo 1 - Anagrafica

(solo sulla macchina Master)

La creazione di una nuova tessera è suddivisa in tre passi.

In questo primo passo il numero della tessera viene generato automaticamente
o creato dal comando di menù Emetti una tessera con il Numero ....

Devono essere obbligatoriamente inseriti i campi Nome e Cognome mentre le altre voci sono facoltative.

E' anche necessario scegliere ora se la tessera da creare sarà dedicata agli eventuali Visitatori occasionali o ad un utente regolare della Biblio-Mediateca.

Una volta inseriti i dati disponibili con il comando Avanti si passerà al secondo passo: la fotografia dell'utente.
Con il comando Annulla si abbandona la creazione della tessera e si ritorna alla finestra principale di ricerca.

Il comando Registra la Tessera senza la fotografia (non utilizzabile per le Tessere Visitatori) permette di generare una nuova Tessera senza la fotografia; in tal caso al posto della foto comparirà :

e cliccandovi sopra (solo sulla macchina Server e solo se non ci sono modifiche in corso) si evidenzierà una finestra simile a quella del secondo passo della normale creazione:

che permetterà di inserire la foto in un secondo momento e di precedere con la stampa della tessera.

NB: Se la fotografia non è presente non sarà possibile stampare la tessera o un suo duplicato!


New willer - passo 2

Creazione nuova tessera: passo 2 - Fotografia

(solo sulla macchina Master)

In questo secondo passo della creazione di una nuova tessera si deve acquisire la fotografia dell'utente.

E' possibile prelevarla da un file con il comando Preleva la foto da un file o da una sorgente esterna di tipo TWAIN (scanner, macchina fotografica, telecamera ecc.) con il comando Preleva la foto da una sorgente.

Per una Tessera visitatori si consiglia di utilizzare delle immagini predefinite prelevandole da opportuni files.

I comandi di prelievo da una sorgente esterna dipendono dalla sorgente stessa e dal suo driver TWAIN installato.

Fare attenzione che alcuni driver TWAIN non gestiscono correttamente il comando "annulla" e possono bloccare il programma! Si consiglia di verificarne la funzionalità ed eventualmente cancellarli oppure di dare conferma e, successivamente, selezionare un'altro driver se disponibile.

Una volta prelevata l'immagine essa verrà mostrata nell'area di sinistra mentre in quella di destra verrà mostrata la porzione di immagine da utilizzare per la tessera.
E' possibile selezionare la porzione di immagine da usare premendo il bottone sinistro e trascinando il mouse nell'area di sinistra e la porzione selezionata verrà indicata dal rettangolo rosso tratteggiato.
La fotografia finale deve essere di 180 pixel di larghezza e 240 pixel di altezza pertanto il sistema adatterà automaticamente le proporzioni della selezione a tali valori e aggiornerà la fotografia una volta rilasciato il mouse.

La selezione è ripetibile fino ad ottenere un risultato giudicato soddisfacente. Si può anche ripetere l'acquisizione ecc. ecc.

Infine si passerà alla terza fase utilizzando il comando Avanti o, se necessario, si potrà tornare alla prima fase con il comando Indietro.

N.B.: in questa fase non è possibile abbandonare la creazione della tessera, si dovrà tornare al passo precedente e annullare con l'apposito comando.


New willer - passo 3

Creazione nuova tessera: passo 3 - Stampa Tessera

(solo sulla macchina Master)

in questo terzo ed ultimo passo della creazione di una nuova tessera verrà mostrata un'anteprima della tessera e sarà possibile inviarla alla stampante e registrarla.

Nota: Se si è selezionato all'avvio l'opzione Non stampare il Codice a Barre sulla Tessera il codice a barre non verrà né visualizzato né stampato.

Per inviare la tessera alla stampante sarà necessario:

  • Selezionare la stampante (a colori) da utilizzare
  • Indicare un offset della posizione di stampa sul foglio (in millimetri)
  • Fornire il LOGO da utilizzare come riportato nella parte bassa della finestra
  • Facoltativamente fornire lo SPONSOR da stampare sulla parte posteriore

I comandi disponibili sono Stampa per inviare la tessera alla stampante ed Indietro per tornare al passo precedente della creazione di una tessera.

Una volta avviato il processo di stampa verrà mostrato il messaggio:

e, confermando, si procederà alla sua archiviazione, si chiuderà la fase di creazione e la tessera risulterà automaticamente selezionata nella finestra principale.

Se il processo di stampa non è andato a buon fine rispondere NO alla domanda, verificare la funzionalità della stampante o cambiarla e ripetere il comando di stampa.

In alternativa annullare l'emissione in corso ripetendo a ritroso i passi della creazione e riprovare in un secondo momento.

Note:
  • Le voci "LOGO" e "SPONSOR" sono modificabili solo dall'operatore privilegiato previa attivazione del comando Abilita modifiche.
  • L'immagine da utilizzare può essere ricercata con il comando Trova ... o il suo percorso può essere digitato direttamente nel campo sottostante. Se l'immagine viene trovata tale campo risulterà colorato in verde altrimenti in bianco.
  • Nell'inserimento del logo o dello sponsor si tengano presenti le dimensioni (Larghezza x Altezza) consigliate per ciascuna immagine in modo da ottenere un risultato soddisfacente.
  • Nella cartella del programma sono presenti due files LOGO.GIF e SPONSOR.GIF che si possono usare come prototipo per creare le immagini precedenti di dimensioni corrette.


Willer - Pagine gestione

Gestione di una tessera

Elenco delle pagine:

Selezione della tessera

Dati anagrafici

Dati avanzati

Assegnazione PC

Duplicato tessera

Visitatori occasionali


Ricerca Willer

Ricerca e selezione Utente o Tessera

La ricerca della Tessera o dell'Utente può essere effettuata inserendo il Nome, il Cognome e/o il Numero di tessera negli appositi campi della maschera ed effettuare la ricerca singolarmente premendo invio dopo aver inserito il criterio di ricerca nel corrispondente campo (gli altri campi verranno automaticamente azzerati) o usando tutti e tre i campi come criteri utilizzando il comando Avvia la ricerca usando tutti i criteri sopraindicati

Verranno elencate solo le tessere che, all'interno di ciascuno dei campi indicati contengono la parte di testo scritta.
Nella schermata di esempio sopra riportata si è indicato di ricercare le tessere che hanno:

  • un 3 nel numero di tessera;
  • una I nel nome dell'utente
  • una I nel cognome dell'utente
utilizzando il comando Avvia la ricerca usando tutti i criteri sopraindicati.
La lista risultante è visualizzata sulla sinistra, ordinata per Utente (è possibile selezionare l'ordinamento per numero di tessera), e si può vedere come ciascuna riga contiene le richieste in una posizione differente.

E' inoltre possibile usare in comando Elenca tutte le tessere per ignorare i criteri di ricerca suddetti.

E' presente il comando: Continua la ricerca inserito per limitare la lunghezza dell'elenco delle tessere.
Vengono mostrate solo fino a 100 tessere alla volta, il comando Continua la ricerca permette di passare alle tessere successive.

Una volta individuata la tessera / l'utente sulla quale agire si deve fare un "doppio click" sulla riga corrispondente e compariranno i dati della tessera, il suo status nonchè le altre possibilità di intervento:

Qualora la tessera non risulti correttamente abilitata verrà anche emesso un messaggio di attenzione (vedi Dati avanzati):

Se una tessera risulta sospesa, scaduta o disabilitata sarà comunque possibile accedere alla stessa
ma non sarà possibile procedere ad acquisti
mentre sarà possibile stampare lo storico degli acquisti stessi o (sulla macchina Master) rimborsare la disponibilità residua.


Anagrafica Willer

Dati anagrafici della Tessera

E' possibile inserire o modificare i dati riportati.

Solo sulla macchina Master e solo da parte dell'operatore privilegiato !
 è possibile scambiare il nome e cognome (per un errore di digitazione) o marcare una tessera come da cancellare .
La predisposizione alla cancellazione non potrà aver luogo se sono presenti residui di disponibilità economica in quanto per le tessere marcate come da cancellare non sarà possibile accedere alle altre sezioni del programma (gestione economica, duplicati, assegnazione PC ecc.)
In tal caso verrà emesso un apposito messaggio di informazione.

La cancellazione effettiva verrà effettuata con il programma ausiliario WillerUtilities.


Avanzati Willer

Dati avanzati della Tessera

Per ciascuna tessera (che non sia una Tessera visitatori) è possibile definire due autorizzazioni (dette Permanente e Temporanea) per ciascuna dei quali si definisce se:

  • La tessera è abilitata, disabilitata, sospesa o scaduta;
  • L'intervallo temporale di validità della tessera (obbligatorio per l'autorizzazione temporanea);
  • L'intervallo di tempo in cui la tessera viene considerata sospesa;
  • Il profilo di utenti al quale la tessera appartiene:
Le modifiche alle autorizzazioni saranno attivate con il comando Verifica e Registra Autorizzazioni Utente il quale controllerà la coerenza dei dati immessi fornendo, se del caso, dei messaggi di errore come i seguenti di esempio:

e non verrà effettuata la registrazione fino a corretta compilazione dei campi.

Normalmente una nuova tessera parte con l'autorizzazione permanente abilitata al profilo Generico (! nessuno) senza scadenza e con quella temporanea disabilitata.
Le tessere visitatori vengono sempre generate con un'autorizzazione permanente al profilo Generico non modificabile.

Il sistema calcolerà, ad ogni avvio del programma ed ad ogni accesso alla tessera da parte dell'operatore, quale sia lo stato attuale di essa in base alle autorizzazioni qui definite ed aggiornerà automaticamente l'archivio delle tessere stesse.
Le autorizzazioni verranno automaticamente aggiornate quando si verificherà l'inizio o la fine di una sospensione o quando arriveranno a scadenza le abilitazioni.

All'accesso alla tessera da parte dell'operatore il sistema emetterà un messaggio se essa non risulta abilitata almeno temporaneamente:

Se una tessera risulta sospesa, scaduta o disabilitata sarà comunque possibile accedere alla stessa
ma non sarà possibile procedere ad acquisti
mentre sarà possibile stampare lo storico degli acquisti stessi o (sulla macchina Master) rimborsare la disponibilità residua.
Il campo Password utente serve per inserire una password (da 6 a 16 caratteri) che l'utente dovrà digitare per accedere al PC assegnatogli (solo per licenze di livello 3 o superiore)
Nel caso non venga inserita nessuna password l'accesso avverrà con il metodo di generazione automatica della password (vedi Assegnazione alla tessera di una macchina).

Anche le tessere visitatori potranno avere una password fissa che l'operatore comunicherà di volta in volta al visitatore stesso ma si consiglia di lasciare il campo vuoto e di utilizzare il metodo di generazione automatico sopraindicato.

Ciascuna modifica a tale password verrà registrata nel sistema di sicurezza.

E' anche possibile inserire delle Note o Autorizzazioni come un testo (250 caratteri massimo) e utilizzare una apposita cartella riservata alla tessera nella quale conservare qualsiasi tipo di file (p.es. fotocopia del documento di autorizzazione per i minori od altro).
Il comando Apri la cartella dei documenti relativi alla Tessera permette appunto di aprire tale cartella (creandola se non esiste già) per l'uso diretto da parte di Windows.

NB: la posizione delle cartelle dei documenti sull'hardDisk è definita in fase di avvio.


Assegna Willer

Assegnazione o prenotazione di un PC

E' richiesta un licenza di livello 3 o superiore !

Da questa maschera è possibile gestire l'assegnazione agli Utenti (o la prenotazione) dei PC della Biblio-Mediateca.

Se il controllo automatico è attivo le macchine saranno gestite dal programma altrimenti la gestione sarà manuale con registrazione degli eventi di assegnazione e revoca.

Nella finestra sono elencate tutti i PC gestibili con il loro mome e lo stato di uso o di prenotazione relativo alle ultime 4 ore ed alle successive 20. (la riga verticale indica l'ora attuale)

Se vi sono più di 10 PC verranno visualizzati dei comandi [image] [image] di scorrimento dell'elenco.

I nomi dei PC sono evidenziati con i colori:

se il PC non è gestito dal controllo automatico,
se il PC è fuorilinea,
se il PC può essere solamente prenotato (l'assegnazione è delegata ad un'altra postazione operatore).
se il PC può essere assegnato da questa postazione operatore ed è disponibile,
se il PC è in fase di connessione a Willer oppure di autenticazione o fine sessione dell'utente,
se il PC è in uso da parte di un utente,
se il PC è in manutenzione temporanea,
se il PC è in manutenzione permanente

Lo stesso colore è riportato nella finestra della macchina selezionata ed è aggiornato in tempo reale con lo stato pervenuto dal PC.

"Cliccando" sul nome di un PC esso viene selezionato e nella parte alta della maschera comparirà il suo nome e le possibili azioni:

  • Assegnazione alla tessera: bisognerà scegliere la durata e premere sul comando Assegna;

    Note: (Modificate nella versione 5)

    • Se la macchina NON è gestita dal controllo automatico
      avverrà solo la registrazione dell'assegnazione manuale negli eventi di sicurezza
      e sarà necessario liberare la macchina sempre con un comando manuale;

    • Se la macchina è gestita dal controllo automatico
      sulla macchina utente assegnata comparirà una finestra con il numero della tessera e la richiesta della Password dell'utente per effettuare l'accesso reale.
      L'utente dovrà digitare correttamente la sua password entro 120 secondi ed avrà tre tentativi a disposizione.
      In caso di errore l'accesso sarà automaticamente annullato.

      La predetta password sarà stata indicata dall'utente e registrata nell'archivio.
      Per le tessere visitatori l'eventuale password registrata sarà sempre ignorata.

      Qualora in fase di avvio non si sia programmato di non richiedere la password per i visitatori occasionali o di renderla facoltativa per gli utenti, ed essa non sia stata predisposta, verrà creata da Willer utilizzando:

      • La prima lettera del Nome dell'utente (o del visitatore occasionale);
      • La prima lettera del Cognome dell'utente (o del visitatore occasionale);
      • Gli ultimi quattro caratteri del codice della tessera.

      Per esempio all'utente (o visitatore occasionale):
      Stefano Dall'Arzere con la tessera ELVIS01515
      verrà assegnata la password: sd1515 (notare che essa è tutta in minuscolo).

  • Prenotazione per la tessera: bisognerà indicare la data (giorno / mese/ anno) e l'ora (ore : minuti) successiva all'attuale, scegliere la durata e premere sul comando Prenota;

Il sistema verificherà che l'assegnazione o la prenotazione siano compatibili con lo stato attuale delle assegnazioni e prenotazioni ed emetterà dei messaggi di errore o registrerà l'azione richiesta.

Per la macchina selezionata è possibile, con un clic sul nome presente nel riquadro della macchina selezionata, visualizzarne lo stato:

e, se attivo, allungare il periodo di uso della macchina (di 10, 15, 30, 45 o 60 minuti), liberare immediatamente l'uso in corso (resteranno comunque 2 minuti all'utente per salvare i lavori) o cancellare una prenotazione attiva.
E' anche possibile, se è in linea e disponibile, mettere la macchina in Manutenzione temporanea o permanente (solo da parte di un operatore privilegiato) o inviare un comando per spegnerla (anche se è in uso).

Analogamente cliccando sul codice della tessera visualizzato in alto sarà possibile vedere lo stato di impiego delle macchine associate:

Sono riportati (dalla versione 5.1) i minuti già utilizzati dalla tessera nel giorno in corso (solo se Willer ha il controllo delle macchine utenti e non fa parte di un sistema Master/Slave) ed è possibile, se attivo, allungare il periodo di uso della macchina (di 10, 15, 30, 45 o 60 minuti), terminare immediatamente l'uso in corso nonché cancellare una prenotazione o attivare una prenotazione che è giunta "a maturazione".


Duplicato Willer

Genera un duplicato della Tessera

(solo sulla macchina Master)

Per ciascuna tessera è possibile emettere fino ad un massimo di 3 duplicati in caso di smarrimento ecc.; nell'archivio verrà registrata la data di emissione di ciascun duplicato.
Se ve ne è la disponibilità verrà evidenziato il comando Stampa un duplicato della Tessera.

Per le tessere generate con una versione precedente del programma è possibile ristampare una tessera se nel programma è stato modificato qualche particolare del layout della tessera (la versione del layout è riportata, per le nuove versioni, sulla tessera in basso a sinistra). In tal caso risulterà attivo il comando Stampa Tessera nel nuovo formato anche per le tessere che hanno già esaurito le possibilità di ristampa.

Il comando Stampa un duplicato della Tessera presenterà la finestra:

e sulla tessera verrà stampato il numero del duplicato.

Il comando Stampa Tessera nel nuovo formato presenterà la finestra:

(con lo stesso numero di duplicato della versione precedente) per la ristampa della tessera e la sostituzione all'utente.

Le finestre sono analoghe a quella della prima emissione ma non è possibile cambiare la foto.

Se si è selezionato all'avvio l'opzione Non stampare il Codice a Barre sulla Tessera il codice a barre non verrà né visualizzato né stampato.

I comandi disponibili sono Stampa per inviare la tessera alla stampante ed Annulla per tornare alla finestra principale

Una volta avviato il processo di stampa verrà mostrato il messaggio:

e, confermando, si procederà alla registrazione del duplicato o del nuovo formato e si tornerà alla finestra principale.

Se il processo di stampa non è andato a buon fine rispondere NO alla domanda, verificare la funzionalità della stampante o cambiarla e ripetere il comando di stampa.

Note:
  • Le voci "LOGO" e "SPONSOR" sono modificabili solo dall'operatore privilegiato previa attivazione del comando Abilita modifiche.
  • L'immagine da utilizzare può essere ricercata con il comando Trova ... o il suo percorso può essere digitato direttamente nel campo sottostante. Se l'immagine viene trovata tale campo risulterà colorato in verde altrimenti in bianco.
  • Nell'inserimento del logo o dello sponsor si tengano presenti le dimensioni (Larghezza x Altezza) consigliate per ciascuna immagine in modo da ottenere un risultato soddisfacente.
  • Nella cartella del programma sono presenti due files LOGO.GIF e SPONSOR.GIF che si possono usare come prototipo per creare le immagini precedenti di dimensioni corrette.


Willer - Visitatori

Definizione dei Visitatori occasionali

E' richiesta un licenza di livello 3 o superiore !

Da queste finestre si introducono o si consultano i dati di un visitatore occasionale con la seguente procedura.

Quando si utilizza una Tessera Visitatori viene visualizzato [image] e cliccando sulla scritta VISITATORE si accede alla registrazione o alla consultazione dei dati del visitatore occasionale.

Se la tessera non è ancora associata a nessun visitatore compare la finestra:

nella quale vanno introdotti tutti i dati visualizzati:

e premendo il tasto Registra i dati e autorizza l'accesso i dati saranno verificati e memorizzati ed il visitatore riceverà l'autorizzazione all'uso delle risorse della Biblio-Mediateca.

Se l'autorizzazione è già stata inserita si accede alla consultazione dei dati del visitatore occasionale senza la possibilità di modifica dei dati stessi.

Verrà visualizzato lo stato di Autorizzato se non gli è stata ancora assegnata una delle macchine utenti:

o quello di In Uso se l'accesso alla predetta macchina è stato effettuato.

In quest'ultimo caso i dati personali, la tessera, la macchina assegnata ed il periodo di utilizzazione richiesto verranno automaticamente archiviati in un log protetto per la successiva consultazione tramite il programma WillerUtilities.

Nota
Se il visitatore è Autorizzato ma non ha già in uso una macchina è disponibile il comando Annulla l'autorizzazione in corso per liberare l'associazione Tessera-Visitatore. In questo caso non verrà registrata nessuna informazione sul visitatore.


Willer - Pagine economiche

Gestione economica

Elenco delle pagine:

Versamenti ed acquisti

Gestione della Cassa


Willer economico

Versamenti ed Acquisti

E' richiesta un licenza di livello 2 o superiore !

Per ciascuna tessera è possibile gestire un database economico in cui vengono registrati i versamenti e gli acquisti effettuati nel corso del tempo in base ad un listino prezzi.

Il database di ciascuna tessera conterrà il totale dei versamenti ed acquisti effettuati e le ultime 30 operazioni.

Il listino prezzi è organizzato per Categorie e Voci; è possibile selezionare una categoria ed una voce al suo interno, indicare la Quantità ed il sistema calcolerà il costo dell'operazione in base al profilo attuale della tessera.

E' possibile scrivere nel campo Voce un testo (20 caratteri max) relativo ad un acquisto non previsto nel listino, in tal caso invece della quantità dovrà essere indicato il costo dell'operazione e la voce sarà automaticamente classificata come categoria Varie (codice interno: 9999).

I comandi disponibili sono:

    Acquista che aggiunge una riga all'elenco degli acquisti;
    Cancella la riga selezionata dall'elenco degli acquisti;
    Cancella tutto l'elenco degli acquisti;
Inoltre SOLO SULLA MACCHINA MASTER è possibile accettare un Versamento aggiuntivo che verrà contabilizzato come entrata di cassa ed, eventualmente, rimborsare la disponibilità residua risultante al termine dell'operazione, rimborso che verrà contabilizzato come uscita di cassa.

N.B.: se non vi è disponibilità di cassa
sufficiente per il rimborso verrà
visualizzato il messaggio indicato
ed il rimborso non sarà possibile.

(Se si sta lavorando su una macchina Client le voci Versamento aggiuntivo e rimborsare la disponibilità residua non saranno visualizzate)

Al termine delle operazioni, se la disponibilità residua è positiva e se la tessera risulta Abilitata o se si tratta solo di un rimborso, si potrà procedere con il comando Registra l'operazione e stampa la ricevuta che mostrerà la finestra:

nella quale sono riportate le singole voci in acquisto, gli eventuali versamenti e rimborsi effettuati con il loro codice di listino ed il relativo costo.

E' possibile:

    Annullare l'operazione (si ritorna alla gestione economica senza modifiche);
    Registrare l'operazione senza stampare la ricevuta su carta qualora l'utente non la desideri;
    Stampare e Registrare l'operazione sulla stampante indicata.
Quest'ultima opzione presenterà il messaggio:

che, confermato, provvederà alla registrazione dell'operazione.

E' sempre possibile fornire una visualizzazione dello storico della tessera con il comando Visualizza l'elenco delle ultime operazioni effettuate che mostrerà il riassunto delle operazioni della tessera:

e sarà possibile una sua stampa per l'utente.


Gestione Cassa Willer

Gestione della Cassa

Solo sulla macchina Master

E' richiesta un licenza di livello 2 o superiore !

Un Operatore può prelevare dalla Cassa dei soldi per acquisti inerenti l'ordinario funzionamento della Biblioteca Multimediateca o aggiungere ad essa delle somme fornite dal responsabile della Biblioteca/Multimediateca stessa.

La funzionalità è del tutto analoga alla gestione economica di una Tessera ma senza listini predefiniti.
E' possibile inserire più voci digitando la causale del prelievo e la cifra corrispondente nonché indicare la cifra aggiuntiva da mettere in cassa.

Con il tasto Annulla si abbandona l'operazione mentre con il tasto Registra l'operazione e stampa la ricevuta si passerà alla registrazione e stampa della ricevuta :

che costituirà il giustificativo del Prelievo stesso.

L'operazione potrà essere completata con la stampa della ricevuta. Si presenterà il messaggio:

che, confermato, provvederà alla registrazione dell'operazione.


Willer - Pagine definizioni

Definizioni

Elenco delle pagine:

Modifiche agli Operatori

Profili di utenti

Macchine associate

Listino prezzi locale


Operatori Willer

Definizione degli Operatori e delle Password

Nella finestra sarà possibile cambiare il nome e la password dell'operatore corrente o di tutti gli operatori se l'operatore corrente è quello principale.

L'operatore principale può anche abilitare o revocare l'abilitazione di uno degli altri operatori nonché assegnargli o revocargli i privilegi di amministratore.

Nell'esempio l'operatore principale (sys) ha abilitato due operatori: Mario (operatore normale) e Nicola (operatore privilegiato) e sta assegnando la password al secondo. Le modifiche non sono ancora state registrate.

Verranno mostrate solo le voci modificabili.

Per cambiare il nome è sufficiente scriverlo nell'apposito campo (massimo 8 caratteri), per cambiare la password bisognerà premere sul corrispondente comando Cambio Password e verrà visualizzata la parte destra della finestra.
In tale area dovrà essere inserita la vecchia password dell'operatore (o quella dell'operatore principale), la nuova password da usare (massimo 8 caratteri) e ripetere per conferma quest'ultima.
Premendo sul comando Conferma sarà verificata la liceità della richiesta e apportate le modifiche alla password.

Come ulteriore livello di sicurezza nessuna modifica sarà apportata all'archivio se non esplicitamente confermata dal comando Registra le modifiche apportate agli Operatori.


Definizione Utenti Willer

Definizione dei Profili di utenti

(solo sulla macchina Master)

I profili di utenti sono gestibili solo dall'operatore privilegiato.

E' possibile inserire fino a 30 Profili di utenti, raggruppati in tre differenti tipi di profilo, che verranno utilizzati per specificare l'autorizzazione (permanente o temporanea) di una tessera.
Ciascuno dei tipi di profili può contenere 10 profili di utenti.

A ciascuna tipologia (Profilo tipo "A", Profilo tipo "B" e Profilo tipo "C") corrisponderanno nel listino prezzi dei differenti costi per ciascuna voce di listino.

Nel Livello 3 - sicurezza (o superiori) i profili degli utenti assumono anche il significato di livello di accesso alle risorse (PC) della Biblio-Mediateca.

Per questo motivo dal livello 3 in poi per ogni profilo vengono visualizzati altri tre campi:

  • Nome utente windows che riporta il nome necessario a questo profilo per richiedere l'accesso ad una delle macchine utenti
    Il sistema accetterà come caratteri validi solo le lettere alfabetiche ed i numeri ad esclusione dell'ultimo carattere che potrà essere uno dei caratteri @ # ! il cui scopo è decritto alla voce Nome eventuale Dominio di accesso
    Il sistema provvederà comunque ad eliminare i caratteri diversi dalle lettere alfabetiche o numeri dal testo inserito, escluso l'eventuale ultimo carattere, pertanto digitando come utente Windows "Gianni A. De' Pisis@" il nome verrà automaticamente convertito in "GianniADePisis@" sopprimendo i caratteri non alfanumerici e gli spazi introdotti e conservando l'eventuale ultimo carattere speciale.

  • Password di accesso che riporta la relativa password associata
  • Ripeti per conferma che verifica la corretta digitazione della password ed abilita il salvataggio dei dati se corretti.
Analogamente tre campi simili sono presenti per l'uso da parte del profilo "Generico" che verrà automaticamente utilizzato se una tessera non è associata ad uno specifico profilo utente (come, p.es. le Tessere visitatori).

Per modificare, inserire o cancellare un profilo è sufficiente digitare il nome dello stesso nella colonna del tipo di profilo al quale si intende associarlo.

A seguito di una variazione si abiliterà il comando Registra le modifiche apportate per renderle operative.

Note:

  • Se un profilo viene cancellato (cancellando il suo nome) esso non sarà più visibile e, di conseguenza, le tessere il cui profilo facesse riferimento a quella voce verranno riclassificate nella voce "! nessuno" (visualizzato come "GENERICO") per il quale si applica il Costo Base del listino prezzi e la corrispondente modalità di accesso alle macchine.

  • Tutte le macchine utenti dovranno essere configuate per utilizzare gli stessi "Username" e le stesse "Password" per l'accesso.
    Fa eccezione la fase di Manutenzione per la quale ciascuna macchina può utilizzare un username ed una password differente da dichiarare in fase di definizione della macchina.
    Vedere anche la voce     Nome eventuale Dominio di accesso per formulazioni dell'accesso più complesse.

  • Più profili utenti di Willer possono utilizzare gli stessi valori per le voci Nome utente windows e Password di accesso per limitare il numero di Username da creare sulle macchine utenti.


Associate Willer

Definizione delle macchine associate

E' richiesta un licenza di livello 3 o superiore !

Da questa finestra è possibile aggiungere, modificare o cancellare i PC da gestire per l'assegnazione agli Utenti.

Aggiungere, modificare o cancellare i PC si potrà fare solo sulla macchina Master.
Le macchine Slaves avranno attivo solo il comando
   Assegna la sua gestione a questo Computer
per la presa in carico del controllo automatico.
Ricorda:
L'attivazione delle nuove definizioni o modifiche
avverrà in modo coerente SOLO dopo il riavvio
del programma su TUTTE le macchine (sia Master che Slaves) !
Anche se sembrerà che talune funzionalità siano corrette è NECESSARIO comunque riavviare !

Per ciascun PC viene definito:

  • Il Nome della Macchina (dovrà corrispondere a quello dichiarato sul programma di controllo installato sulla macchina utente) Non ci potranno essere due PC con lo stesso nome, il programma si proteggerà rifiutando la registrazione delle modifiche!

    Nuovo nella versione 5

    • Se nel nome della macchina viene inserito un punto (p.es.: TEST_PC.0) quella macchina NON sarà gestita dal sistema di controllo automatico ma solo in modalità manuale.
    • Se il controllo automatico NON viene abilitato tutte le macchine saranno gestibili solo in modalità manuale.

  • La Chiave di comunicazione criptata (dovrà corrispondere a quella dichiarata sul programma di controllo installato sulla macchina utente) che sarà usata se la criptazione è abilitata

  • Da quale postazione operatore è attualmente gestita l'assegnazione agli utenti (nel caso di più macchine "Willer" di gestione)
    Per default la gestione di un nuovo PC inserito sarà automaticamente assegnata alla macchina Master.
    Una volta introdotte e salvate le definizioni intervenire sulla macchina Slave per prenderne il controllo se è opportuno.

  • Per l'accesso alla Manutenzione (Temporanea o Permanente) della macchina vengono richiesti i parametri:
    • L' Username con cui si accederà alla macchina (è opportuno che sia uno degli amministratori)
      Vedere anche la voce Nome eventuale Dominio di accesso per formulazioni dell'accesso più complesse.
    • La relativa Password necessaria per l'accesso
    • La ripetizione della stessa per la verifica della digitazione precedente (in verde quando sono coincidenti)
    • Un comando Salva dati, attivo se i dati sono stati modificati e sono validi, per memorizzare i predetti parametri di accesso nella definizione della macchina.

Una volta definiti, o modificati, tutti i PC interessati si salvano le modifiche per registrarne le definizioni.


Listino Willer

Gestione del Listino Prezzi Locale

E' richiesta un licenza di livello 2 o superiore !

(solo sulla macchina Master)

Il listino è gestibile solo dall'operatore privilegiato.

Il Listino Prezzi è organizzato in sezioni:

  • Una sezione Comune che conterrà le Categorie (da 10xx a 49xx) comuni a più Istituzioni (Biblioteche ecc.) e sarà creata e modificata da una istituzione Capofila per la distribuzione alle altre. Lo scopo di tale sezione è quello di avere delle Voci di riferimento comuni per la generazione di statistiche.
  • Una sezione Locale che conterrà le Categorie (da 50xx a 89xx) di interesse locale e sarà creata e modificata direttamente con questa finestra.
Ai fini della gestione economica le diverse sezioni saranno considerate come un unico listino.
Per ciascuna voce si indicherà il costo unitario di base dell'operazione.

I comandi disponibili sono:

  • Aggiungi una categoria al listino (20 caratteri massimo)
  • Aggiungi una voce alla categoria selezionata (20 caratteri massimo)
  • Modifica la descrizione della categoria (20 caratteri massimo)
  • Modifica la descrizione della voce (20 caratteri massimo)
in corrispondenza a ciascun comando si aprirà una "inputBox" in cui

scrivere il nome della nuova categoria:
o della nuova voce:
o riscrivere il nome della categoria:
o della voce:

"Cliccando" su una delle categorie verrà visualizzato l'elenco delle voci esitenti per quella categoria; "cliccando" su una delle voci verranno visualizzati i costo unitari della voce e sarà possibile modificarli scrivendo il costo negli appositi campi.

I comandi indicati con le figure [image] permettono di ricopiare il costo dalla casella precedente senza doverlo riscrivere.

Oltre al Costo Base, che si applica alle tessere senza uno specifico profilo, è possibile indicare i costi dei tre tipi di Profili (Profilo tipo "A", Profilo tipo "B" e Profilo tipo "C"); essi si applicheranno alle tessere in base al profilo utente in corso di validità.

Il comando Stampa Listino (attivo solo se non ci sono modifiche) permette di stampare il listino in formato testo per documentazione. La stampa riporterà anche le voci di un eventuale listino comune utilizzato.

Il listino non verrà modificato permanentemente fino a quando non verrà dato il comando Registra ed attiva il listino che provvederà anche alla stampa dello stesso, mentre il comando Annulla ripristinerà il listino originario annullando tutte le modifiche introdotte.

Note:

  • La numerazione (codice interno) delle categorie e delle voci è totalmente automatica e consecutiva.

  • E' possibile inserire nel campo Note generali sul listino un testo (250 caratteri massimo) contenente il riferimento a delibere, validità ecc. ecc. Esso verrà utilizzato in fase di stampa del listino come titolo del listino stesso.


ElvisControl - Funzionamento

Funzionamento del Controllo automatico

In questa pagina viene descritto in funzionamento operativo del sistema di controllo automatico.
Per la procedura di installazione e le specifiche tecniche consultare le pagine:

  • Generalità

  • Prerequisiti per Windows 98

  • Prerequisiti per Windows 2000 e XP

  • Installazione del Controllo automatico

L'attivazione del controllo automatico delle macchine Client determina il seguente funzionamento di esse:

1. All'avvio di una macchina Client controllata da Willer viene presentata la finestra a fianco che rimane visibile finchè l'operatore di Willer non invia un comando di assegnazione della macchina ad una Tessera (eventualmente di tipo Visitatori).

Modificata nella nuova versione del Client
Il precedente tasto di spegnimento è stato soppresso.
E' possibile, in questa fase, forzare lo spegnimento della macchina digitando la frase preprogrammata (default: "Spegni la macchina", programmabile con "ConfigurationManager" in fase di installazione, come tutti gli altri messaggi) e premendo il tasto Invio.
Se la frase digitata è corretta (non distingue tra maiuscole e minuscole) verrà visualizzata una finestra di informazione ed avviata la procedura di spegnimento.

2. L'operatore di Willer invia l'assegnazione della macchina specificando (in automatico) :

  • Il codice della Tessera
  • La password che l'utente dovrà digitare
  • L'usermane che verrà usato per l'accesso a Windows
    (selezionato in base al profilo utente assegnato a quella tessera)
  • La corrispondente password valida per l'accesso a Windows
  • La durata del periodo di utilizzo della macchina
  • Quanto tempo prima della scadenza dovrà essere visualizzato il messaggio di scadenza di cui al punto 5

    • (Il tempo di preavviso è fissato in circa un decimo del periodo di utilizzo concesso
    con un minimo di 2 minuti ed un massimo di 10 minuti salvo diversa programmazione.)

3. Se è richiesta una password la macchina utente visualizza la finestra:
L'utente ha 120 secondi per digitare correttamente la sua password e premere il tasto OK.
(30 secondi massimo tra un carattere e l'altro).

3a. Se l'utente sbaglia la password verrà visualizzata la finestra:

3b. Se l'errore viene ripetuto per tre volte verrà visualizzata la finestra e l'accesso verrà annullato tornando al punto 1.

4. Se la password è corretta, o non è richiesta, verrà avviato Windows con il profilo corrispondente all'Username inviatogli e per la durata indicata (a tale tempo verrà sottratto quello impiegato per inserire la password).

5. Prima dello scadere del periodo di utilizzazione verrà visualizzato il messaggio a fianco ed al termine l'utente verrà disconnesso e la macchina tornerà al punto 1.

6. L'utente potrà in ogni momento chiudere la sua sessione con il comando Disconnetti ... e la macchina tornerà al punto 1.

Il comando di Manutenzione (Temporanea o Permanente) porterà la macchina direttamente dal punto 1 al punto 4 senza alcuna richiesta di password ed inoltre non vi sarà alcuna scadenza dell'utilizzo.
Se la macchina è in Manutenzione Temporanea il controllo verrà ripreso al prossimo riavvio della macchina o quando verrà chiusa la sessione di manutenzione; se è in Manutenzione Permanente sarà necessario riattivare il controllo con la procedura specificata in fase di installazione del Controllo Remoto.

Se l'operatore invia un comando Liberare la macchina l'utente riceverà il messaggio di cui al punto 5 con un tempo di 120 secondi; analogamente se invierà un comando di Spegni la macchina; questo per dare il tempo all'utente di salvare i propri lavori in corso.

Nota:
Ricordarsi di disattivare, tra le altre cose, la voce Chiudi sessione (con un opportuno programma o gestore della policy) per evitare che l'utente spenga la macchina invece di chiudere la sua sessione.
Analogamente sarà opportuno disattivare la voce Esegui... ed il TaskManager (nonché la sequenza di tasti CTRL+ALT+CANC).


Main Utilities

Utilities di Willer

Il programmaWillerUtilities, fornito come modulo separato, consente di agire sugli archivi di Willer per estrarre le informazioni utili ai fini statistici o di documentazione, per eseguire delle copie di sicurezza (backup) degli archivi nonché il loro ripristino, per generare un Listino Comune da condividere con altre Biblio-mediateche.

E' opportuno che questo programma venga utilizzato SOLO quando nessun PC accede agli archivi, cioè quando tutti i programmi Willer sulle varie macchine in rete siano stati fermati.
Ciò per garantire la coerenza degli archivi.

Il programma verificherà se vi sono macchine (PC) che hanno ancora Willer in funzione; in tal caso verrà emesso un messaggio del tipo:

e, continuando, sarà possibile solo la visualizzazione e la eventuale stampa dei rapporti giornalieri delle macchine che risultano correttamente chiuse.
All'avvio viene verificata la coerenza di alcuni dati iniziali e, in modo analogo a Willer, viene richiesto il nome e la password dell'operatore:

Gli operatori sono gli stessi di Willer. Alcuni comandi sono accessibili solo all'operatore privilegiato.
Se non vi è la coerenza richiesta o l'accesso non è corretto il programma termina.

Voci di menù

  • Rapporto giornaliero (vedi Visualizzazione e stampa Rapporto)
    Consente di selezionare la macchina, l'anno, il mese ed il giorno di interesse, di visualizzare e stampare il rapporto di quel giorno così come risulta in archivio.
    Il programma si pone automaticamente su questa voce selezionando il rapporto più recente della macchina su cui si sta operando.

  • Statistiche economiche (vedi Ricerche economiche)
    E' possibile effettuare una ricerca sull'archivio economico in base alle voci:
    • Periodo (dal ... al ...) di ricerca

    • Codice della Tessera

    • Categoria del listino (sia Comune che locale)

    • Voce della categoria

    • Livello di prezzo (Costo base, Profilo "A", "B" o "C")

    • Operatore che ha effettuato l'operazione

    • Macchina (PC) sulla quale è stata effettuata l'operazione

  • Statistiche di sicurezza (vedi Ricerche sicurezza)
    E' possibile effettuare una ricerca sull'archivio di sicurezza in base alle voci:
    • Periodo (dal ... al ...) di ricerca

    • Codice della Tessera

    • Tipo di evento (Inizio, Fine)

    • PC utilizzato dalla tessera

    • Operatore che ha effettuato l'operazione

    • Macchina (PC) sulla quale è stata effettuata l'operazione

    • Nuovo in questa versione: Effettuare la ricerca sull'archivio dei visitatori occasionali.
      In tal caso solo le prime due voci di questo elenco saranno disponibili per limitare la ricerca

  • Gestione delle tessere (vedi Ricerche sulle Tessere)
    Mette a disposizione i comandi

    • Rimuovi le Tessere da Cancellare che è presente solo se vi sono tessere da cancellare.

    • Stampa il risultato della rimozione

    • Salva anagrafica in formato XLS e Salva anagrafica in formato testo
      che permettono di estrarre dall'archivio tessere alcuni dati anagrafici degli utenti e salvarli su un file per ulteriori elaborazioni.

  • Gestione del Listino Comune (vedi Listino Comune)
    (attivo solo per l'operatore privilegiato)

  • Gestione degli Archivi (vedi Backup dell'archivio e Ripristino dell'archivio - solo per l'operatore privilegiato)

  • Uscita dal programma;


Report Utilities

WillerUtilities - Visualizzazione e stampa Rapporto

Consente di selezionare la macchina ed il giorno di interesse, di visualizzare e stampare il rapporto di quel giorno così come risulta in archivio.

Selezionando il nome (di rete) del PC di interesse dal primo elenco vengono mostrati, ordinati per anno, mese e giorno, tutti i rapporti conservati relativi a quel PC con la selezione automatica del più recente.

Selezionando l'anno, quindi il mese ed infine il giorno di interesse viene mostrato il contenuto del rapporto e, se si è selezionata una stampante, sarà possibile effettuarne una stampa.


Ricerca Economica Utilities

WillerUtilities - Ricerche economiche

E' possibile effettuare una ricerca sull'archivio economico in base ai criteri:

  • Periodo (dal ... al ...) di ricerca

  • Codice della Tessera

  • Categoria del listino (sia Comune che locale)

  • Voce della categoria

  • Livello del Listino (Costo base, Profilo "A", "B" o "C")

  • Operatore che ha effettuato l'operazione

  • Macchina (PC) sulla quale è stata effettuata l'operazione

Se non si seleziona una voce (o se si lascia ! tutte) il significato è qualunque valore.

Con il comando Avvia la ricerca verrà generato il risultato della ricerca e tale risultato sarà possibile stamparlo oppure salvarlo sia in un file con formato testo normale (.txt) che in un file con formato testo compatibile con Excel (.xls).

In particolare il comando Visualizza il totale risultante permette di estrarre dall'archivio economico il solo totale (in euro) della ricerca,

di visualizzarlo: ed, eventualmente, stamparlo se vi è una stampante disponibile.

Questo comando opera in maniera particolare:

  • Utilizzerà solo l'eventuale Periodo di ricerca (Dal giorno ... Al giorno ...) programmato ignorando le altre opzioni (Tessera, Categoria, Voce, ecc. ecc.)
  • Indicherà il totale dei servizi erogati in ciascuna categoria del listino, nonché il Totale Generale
  • Per la Cassa indicherà i totali delle singole voci di entrata ed uscita nonché il totale netto dei movimenti di cassa e dovrebbe corrispondere al contenuto della Cassa se la ricerca è estesa a tutto l'archivio
  • Sono riportate, per controllo, anche le dichiarazioni di cassa iniziali e finali del periodo di ricerca

Un ulteriore comando Verifica coerenza dell'Archivio può essere utile nel caso si sospettino problemi di coerenza. Anche il risultato di tale verifica sarà possibile stamparlo ma solo se si evidenziano errori.


Ricerca Sicurezza Utilities

WillerUtilities - Ricerche sicurezza

E' possibile effettuare una ricerca sull'archivio di sicurezza in base ai criteri:

  • Periodo (dal ... al ...) di ricerca

  • Codice della Tessera

  • Tipo di evento (Inizio, Fine)

  • PC utilizzato dalla tessera

  • Operatore che ha effettuato l'operazione

  • Macchina (PC) sulla quale è stata effettuata l'operazione

Nuovo dalla versione 5.0
A fianco della Macchina Usata verrà fornito, se disponibile, l'indirizzo di rete (IpAddress) della macchina stessa.

E' anche possibile scegliere di effettuare la ricerca sull'archivio dei visitatori occasionali spuntanto la voce Ricercare nell'Archivio dei Visitatori nel qual caso sarà possibile usare i soli criteri:

  • Periodo (dal ... al ...) di ricerca

  • Codice della Tessera visitatori interessata

Se non si seleziona una voce (o se si lascia ! tutte) il significato è qualunque valore.

Con il comando Avvia la ricerca verrà generato il risultato della ricerca e tale risultato sarà possibile stamparlo oppure salvarlo sia in un file con formato testo normale (.txt) che in un file con formato testo compatibile con Excel (.xls).

Un ulteriore comando Verifica coerenza dell'Archivio può essere utile nel caso si sospettino problemi di coerenza. Anche il risultato di tale verifica sarà possibile stamparlo ma solo se si evidenziano errori.


Ricerca Tessere Utilities

WillerUtilities - Ricerche sulle Tessere

Mette a disposizione i comandi

  • Rimuovi le Tessere da Cancellare che è presente solo se vi sono tessere da cancellare.

  • Stampa il risultato della rimozione se ve ne sono state

  • Salva anagrafica in formato XLS e Salva anagrafica in formato testo
    che permettono di estrarre dall'archivio tessere alcuni dati anagrafici degli utenti e salvarli su un file per ulteriori elaborazioni.


Listino Utilities

WillerUtilities - Gestione Listino Comune

 (attivo solo per l'operatore privilegiato)

Un Listino Comune conterrà le Voci comuni a più Istituzioni (Biblioteche ecc.) e sarà creato e modificato, possibilmente, da una istituzione Capofila per la distribuzione alle altre. Lo scopo di tale listino è quello di avere delle Voci di riferimento comuni per la generazione di statistiche.

Questa sezione permette di creare e modificare un listino comune con le stesse procedure previste per il listino locale, di salvarlo su un file (.pzc) per la distribuzione alle altre Istituzioni nonché di installare un file ricevuto dall'Istituzione Capofila.

Come per il listino locale il listino comune fa riferimento ai profili di utenti presenti nell'impianto specifico consentendo di assegnare a ciascuno dei quattro:

  • Costo Base (nessun profilo)

  • Profilo tipo "A"

  • Profilo tipo "B"

  • Profilo tipo "C"

un differente costo della voce del listino.

In testa è riportato il nome del file di listino comune che si sta visualizzando.

I comandi di editing relativi alle categorie ed alle voci sono del tutto analoghi a quelli del listino locale.

I comandi aggiuntivi sono:

  • Stampa questo Listino Comune che permette stampare il listino in formato testo;

  • Azzera il contenuto del Listino che predispone un listino vuoto;

  • Carica il Listino Comune dal file ... che permette di selezionare un file (.pzc) di listino comune e di caricarlo per eventuali modifiche.
    Qualora il file che si cerca di caricare non corrisponda ad un listino comune o contenga errori verrà evidenziato un messaggio del tipo:

  • Salva il Listino Comune sul file ... che si attiva in presenza di modifiche e permette di salvare il listino con un nome e su una cartella qualsiasi.

  • Carica il Listino Comune in uso che consente di caricare direttamente il listino comune ListinoPrezzi.pzc attualmente in uso per le modifiche.
  • Sostituisci al Listino Comune in uso che, dopo conferma, consente di sostituire il listino comune ListinoPrezzi.pzc attualmente in uso con quello appena creato o caricato.
    Questo comando non è attivo se il listino è stato modificato; lo scopo di questa limitazione è quello di disporre sempre di una copia separata del listino comune.

Nota: il programma Willer usa come files dei listini dei nomi fissi:

ListinoPrezzi.pzl per il listino locale
ListinoPrezzi.pzc per quello comune
ed entrambi sono nella sottocartella Listini degli archivi di Willer.


Backup Utilities

WillerUtilities - Backup dell'Archivio

Questa sezione permette di generare un file di Backup (.bkw) degli archivi nonché il ripristino degli stessi a partire dal predetto file.

E' possibile selezionare diversi tipi di backup (e di conseguente ripristino):

  • Tutti gli Archivi necessari al funzionamento di Willer è la selezione di default e permette di conservare in un'unico file di backup tutti i files necessari a Willer

  • Tutto il contenuto della directory "Archivi di Willer" che effettua un backup "monolitico" dell'intero contenuto per il trasferimento o la conservazione dei dati (tessere ecc.);

  • Tutto il contenuto della directory "Documenti delle Tessere" che effettua un backup "monolitico" dell'intero contenuto delle cartelle associate alle singole tessere per il trasferimento o la conservazione.

E' inoltre possibile scegliere se creare un file di backup

normale (più veloce) : o compresso (più piccolo) :
Dopo aver selezionato il tipo di Backup desiderato con il comando Esegui il Backup di si entra nella fase di backup.
Verrà richiesto il nome del file in cui salvare il backup (il programma proporrà per default un nome dipendente dal tipo di backup e dalla data ed ora in cui viene effettuato) :

e, confermando, si otterrà un report del risultato:

che sarà possibile stampare.


Ripristino Utilities

WillerUtilities - Ripristino dell'Archivio

 (attivo solo per l'operatore privilegiato)

Questa sezione permette di ripristinare da un file di Backup (.bkw) degli archivi, quanto esposto nell'elenco seguente:

  • Tutti gli Archivi necessari al funzionamento di Willer è la selezione di default e permette di ripristinare tutti i files necessari a Willer

  • Tutto il contenuto della directory "Archivi di Willer" che effettua il ripristino dell'intero contenuto della directory;

  • Tutto il contenuto della directory "Documenti delle Tessere"che effettua il ripristino dell'intero contenuto della directory.

Notare che il backup è stato modificato nel formato rispetto alle versioni 3.x.x pertanto non sarà possibile ripristinare dei backups generati con le precedenti versioni !

Dopo aver selezionato il tipo di Ripristino desiderato con il comando Ripristino dal Backup di si entra nella fase di ripristino. Verrà richiesto il nome del file da cui prelevare il backup (indifferentemente normale o compresso):

A questo punto verrà controllato che il ripristino richiesto sia disponible nel file di backup indicato altrimenti verrà segnalato un errore:

successivamente, se non si è selezionata la casella Ripristinare nella posizione attuale degli archivi di Willer, verrà richiesta la directory in cui effettuare il ripristino:

Quindi verrà richiesto di confermare l'operazione:

e, confermando, si otterrà un report del risultato:

che sarà possibile stampare.


Willer - Pagine appendice

Appendice

Elenco delle pagine:

Localizzazione archivi

Conversione vecchi archivi

Stampante per ricevute

Eventi di sicurezza

Struttura del file ini

Errori e rimedi


Localizzazione Archivi Willer

Localizzazione degli archivi

(nella versione Demo i nomi dei files creati hanno il prefisso "DEMO_")

In ciascun PC verrà creata una cartella del programma (tipicamente C:\Programmi\Willer) contenente, oltre ai programmi Willer.exe e WillerUtilities.exe, al manuale Willer.chm e ai file Logo.gif e Sponsor.gif (che servono come esempio per le dimensioni dei logo e sponsor da stampare sulla tessera), il file InstallaServer.bat e le cartelle ElvisControl, ClientControl e ClientService per l'istallazione ed il funzionamento del sistema di controllo.
Tutti questi files sono necessari e NON devono essere modificati a mano o cancellati.

Al primo avvio verranno anche creati un file con le inizializzazioni locali Willer.ini ed un file con la licenza Willer.licenza

Il file di licenza non dovrà essere modificato in alcun modo o il programma richiederà l'immissione di una nuova licenza; esso potrà essere copiato in una delle altre macchine Willer per evitare di reinserire manualmente i dati della licenza.

Il file Willer.ini contiene le definizioni di partenza.
In fondo a detto file vi è una nota per cui si può alterare un numero (legato alla licenza) :

....
....
....

.-------------------------------------------------------------------------.
" Modificando il numero seguente si riabilita la procedura di primo avvio "
`-------------------------------------------------------------------------'
1375986380
***********************************************
* Fine delle dichiarazioni di avvio di Willer *
***********************************************
p.es. aprendolo con il blocco note e cancellando l'ultima cifra di esso, se si ritiene necessario modificare i parametri di configurazione facendo ricomparire la finestra di primo avvio.

Ciò può anche essere utilizzato nell'installazione di Willer su altre macchine copiando tale file in esse, assieme alla licenza, ed alterando su di esse il numero indicato prima di avviare Willer per la prima volta su questa nuova macchina.

Attenzione: l'uso del metodo sopraindicato comporta che i parametri di avvio:

  • Questa macchina è l'unica dedicata alla gestione del sistema
  • Verificare la scadenza di una tessera solo quando vi si accede
  • Questa macchina può emettere le Tessere o modificare i Listini
  • Questa macchina gestisce in automatico le macchine utenti
saranno riportati ai valori di default ! (rispettivamente: si, si, no, no)
Prestare attenzione a rimetterli al loro corretto valore desiderato.
Gli archivi in comune tra le diverse macchine dovranno, ovviamente, essere localizzati in un server di rete (o in una macchina che sia sempre accesa e metta in condivisione di rete le risorse necessarie) e sia le macchine Master che le Slaves dovranno avere i permessi di accesso completo cioè i permessi di Lettura, Scrittura e di Cancellazione, .

Le cartelle richieste in fase di installazione del programma sono:

    Posizione dell'Archivio di Willer ...
    Posizione dell'archivio delle cartelle associate alle Tessere ...
e queste cartelle dovranno essere condivise in rete.

Nella cartella indicata da Posizione dell'archivio delle cartelle associate alle Tessere verrà creata, per ciascuna Tessera, una sottocartella di nome uguale al codice delle tessera, nella quale conservare i files associati a quella Tessera.

Nella cartella indicata da Posizione dell'Archivio di Willer verranno creati :

  • dei files speciali di sincronizzazione delle macchine (detti semafori)
    questi files potranno essere cancellati manualmente - a Willer fermo - qualora sorgano problemi in fase di avvio,

  • una sottocartella Tessere contenente l'archivio delle tessere, l'archivio dei profili di utenti e gli altri archivi necessari,

  • una sottocartella Listini che conterrà i listini (locale e comune) e gli archivi della gestione economica, di sicurezza etc. ,

  • una sottocartella Reports contenente a sua volta delle sottocartelle, una per ciascun PC su cui è installato Willer, con nome uguale a quello di rete del PC stesso (p.es. W98VB6 come nell'immagine).
    In tale sottocartella verrà conservato, per ciascun giorno, un file di testo di nome Report_yyyymmdd.txt :

    che conterrà tutte le operazioni economiche effettuate su quel PC in quel giorno.
    Tale file di report sarà utilizzato da WillerUtilities per la ricerca e stampa dei rapporti giornalieri oppure potrà essere aperto con Notepad o con un programma di elaborazione di testi.
    Il file può contenere righe superiori ai 100 caratteri pertanto si consiglia di stamparlo in orizzontale


Conversione vecchi Archivi Willer

Conversione Archivi da versioni precedenti la versione 3.x

Si consiglia di effettuare quanto qui indicato PRIMA di attivare la nuova versione

L'archivio delle tessere è compatibile con quella delle versioni precedenti a partire dalla versione 1.0.2 .

Nelle versioni precedenti la 3.x gli archivi sono localizzati:

  • Il file ArchivioTessere.elv nella cartella indicata nell'installazione del programma.
    Vedere il vecchio file Willer.ini che alla prima riga riporta la posizione di tale cartella.
  • Il file ArchivioUtenti.elu nella stessa cartella.
  • Le cartelle dei documenti degli utenti, come sopra, sono indicati nella seconda riga del file Willer.ini
  • I files dei Listini: ListinoLocale.prz e ListinoComune.prz (se esiste) nonché il file dell'archivio economico LogEconomico.mef è localizzato nella sottocartella Listini del vecchio programma.
Tutti questi files dovranno manualmente essere spostati nelle nuove cartelle indicate in localizzazione degli archivi e da indicare nella fase di avvio.

Sarà sufficiente trascinare i files o le cartelle nella nuova destinazione. Contattare telefonicamente la Elvis per una procedura guidata.

Nota:
La struttura degli archivi dalla versione 3.x in poi ha subito modifiche.
La conversione dei files nell'attuale formato avverrà automaticamente con esclusione di eventuali files di sistema (semafori ecc.) che verranno ignorati e ricreati.

Eventuali versioni precedenti la 1.0.2 dell'archivio tessere richiederanno un apposito programma di conversione segnalato all'avvio del programma con un messaggio tipo:

L'archivio della gestione economica è stato modificato rispetto alle versioni 1.xx; al primo avvio verrà visualizzato il messaggio:

e, confermando il comando, verrà convertito nel nuovo formato.


Setup stampante per ricevute

Setup stampante termica per ricevute

Il programma Willer, dalla versione 3.20, può utilizzare una stampante diversa per i testi e per le ricevute.

Le ricevute, in particolare, sono impaginate per utilizzare una stampante generica da 42 colonne come, p.es., una stampante termica.

  • Configurazione per Windows XP
  • Configurazione per Windows 98

Installazione

In questa appendice viene mostrato come installare una stampante termica (tipo Samsung STP-103) sul sistema operativo WindowsXP (per Windows 98 la procedura è similare).
Questi suggerimenti possono essere usati come traccia per altri tipi di stampanti.

Dal Pannello di Controllo selezionare Stampanti e, quindi, la voce Aggiungi Stampante ottenendo la finestra:

premere Avanti

selezionare la voce Stampante locale ... ,
NON selezionare la voce Rileva e installa ...
e premere Avanti

selezionare la porta alla quale verrà collegata la stampante in base al tipo di stampante

  • COMx: per stampanti seriali come la STP-103G
  • LPTx: per stampanti parallele come la STP-103PG
e premere Avanti

selezionare la voce Generale dalla finestra di sinistra,
la voce Generic / Text Only da quella di destra
e premere Avanti fino al completamento dell'installazione.

Ritorna all'inizio pagina

Configurazione per Windows XP

Dal Pannello di Controllo selezionare Stampanti e, quindi, con il tasto destro del mouse sulla stampante Generic / Text Only selezionare la voce di menù Proprietà ottenendo:

sul pannello Generale inserire il nome della stampante (STP-103 in questo esempio)

sul pannello Comandi Stampante inserire le righe indicate in figura per definire le proprietà di stampa:

  • alla voce Inizio processo di stampa inserire la parte compresa tra le parentesi tonde, escluse, della riga :
    (<1B>@<1B>c51<1B>a0<1B>2<1B>!<01>)

    • (suggerimento: usa copia e incolla)
  • alla voce Fine processo di stampa inserire la parte compresa tra le parentesi tonde, escluse, della riga :
    (<1B>d<05>)
    (suggerimento: usa copia e incolla)

sul pannello Selezione carattere selezionare come Tabella codici:
Multilingua - Latino 1 (850)
e chiudere la finestra.

Ritorna all'inizio pagina

Configurazione per Windows 98

In Windows98 i codici da inserire sono leggermente differenti.

1. Il nome della stampante si modifica direttamente nella cartella Stampanti.

2. In Proprietà - Opzioni periferica

  • alla voce Inizio processo di stampa inserire la riga <ESC>@<ESC>c51<ESC>a0<ESC>2^M
  • alla voce Termina processo di stampa inserire la riga <ESC>d^E^M
  • alla voce Mappatura caratteri selezionare Pagina codici 850

    • lasciando vuoti gli altri campi !

3. In Proprietà - Tipi di carattere

  • alla voce Seleziona 17cpi inserire la riga <ESC>!^A

    • lasciando vuoti gli altri campi !

<ESC>
si ottiene premendo il tasto ESC
^A
si ottiene tenendo premuto il tasto CTRL e premendo A
^E
si ottiene tenendo premuto il tasto CTRL e premendo E
^M
si ottiene tenendo premuto il tasto CTRL e premendo M

Ritorna all'inizio pagina


Eventi di sicurezza

Eventi registrati nell'Archivio Sicurezza

(versione 5.0)

Per ogni evento vengono registrati nell'archivio di sicurezza :

  • Numero dell'evento
  • Tipo dell'evento (vedi tabella)
  • Data dell'evento
  • Data finale dell'evento (per gli accessi)
  • Codice della Tessera, può essere sostituito con
    • .Man.Temp. se è un evento di Manutenzione Temporanea
    • .Man.Perm. se è un evento di Manutenzione Permanente
    • __SERVER__ se è un evento interno a Willer
    • __CLIENT__ se è un evento relativo alla macchina utente
  • Profilo della Tessera (se dispoibile)
  • Macchina origine dell'evento
  • Indirizzo IP della macchina (0.0.0.0 se non disponibile o da archivi con versione precedente la 5)
  • Operatore (e macchina dell'operatore, nel formato: Macchina/Operatore per le versioni da 4 in poi)
  • Checksum di sicurezza

La lista di tutti i tipi di eventi è la seguente :

Testo visualizzato | Dati significativi | Descrizione
Dai vecchi archivi (versione 3.x) |  |
(OLD) Inizio uso | Tessera e Macchina | Vecchio tipo di evento per inizio dell'uso della macchina
(OLD) Fine uso | Tessera e Macchina | Vecchio tipo di evento per fine dell'uso della macchina
Interni al programma Willer |  |
Server avviato | Operatore | Il controllo automatico è stato avviato
Server fermato | Operatore | Il controllo automatico è stato fermato
Cambio password | Operatore e Tessera | La password della tessera è stata modificata
Eventi di accesso manuali |  |
Login manuale | Tessera e Macchina | E' stato consentito l'accesso della Tessera ad una macchina non sottoposta al controllo automatico
Logout manuale | Tessera e Macchina | L'accesso della Tessera ad una macchina non sottoposta al controllo automatico è terminato
Eventi di accesso controllati |  |
Login Autorizzato | Tessera e Macchina | L'accesso della Tessera è stato autorizzato ed è in attesa di password utente
Errore password | Tessera e Macchina | L'utente ha inserito per tre volte una password errata, l'accesso gli è stato negato
Login effettuato | Tessera e Macchina | L'accesso della Tessera è stato effettuato correttamente
Durata allungata | Tessera e Macchina | L'accesso della Tessera è stato prolungato
Richiesto Logout | Tessera e Macchina | E' stata avviata la procedura di Logout della tessera
Logout completato | Tessera e Macchina | La procedura di Logout della tessera è stata completata
Stato delle macchine controllate |  |
PC in linea | Macchina | La macchina è entrata in linea
PC in fuorilinea | Macchina | La macchina è uscita di linea
In attesa comandi | Macchina | La macchina è pronta per ricevere i comandi
Login in corso | Macchina | La macchina è in fase di avvio dell'accesso da parte di una Tessera
Disabilitato | Macchina | La disabilitazione del controllo automatico della macchina è stata completata
Riavvio in corso | Macchina | Il riavvio della macchina è in corso
Spegnimento ... | Macchina | Lo spegnimento della macchina è in corso
Comandi alle macchine controllate |  |
In manutenzione | Operatore e Macchina | E' stato richiesto di mettere la macchina in manutenzione (temporanea o permanente)
Disabilitare PC (non usato) | Operatore e Macchina | E' stato richiesto di disabilitare il controllo automatico della macchina
Riavviare PC (non usato) | Operatore e Macchina | E' stato richiesto di riavviare la macchina
Spegnere PC | Operatore e Macchina | E' stato richiesto di spegnere la macchina
Errori delle macchine controllate |  |
Offline (Timeout) | Macchina | La macchina non ha risposto nei tempi previsti
Errore di login | Macchina | La macchina non è riuscita a dare l'accesso ad una Tessera
Errore di Logout | Macchina | La procedura di Logout di una tessera non è andata a buon fine
Errore Disabilit. | Macchina | La disabilitazione del controllo automatico non è andata a buon fine
Errore di riavvio | Macchina | Il comando di riavvio della macchina non è andata a buon fine
Errore di spegn. | Macchina | Il comando di spegnimento della macchina non è andato a buon fine
Errore interno | Macchina | Si è verificato un errore o un evento non classificato


Willer - Ini

Struttura del file: Willer.ini

Il formato del file Willer.ini è riportato qui di seguito:

420 | Versione di riferimento della struttura
"D:\Dati_Willer\Archivi\" | Directory degli archivi di Willer
"D:\Dati_Willer\Documenti\" | Directory dei documenti delle tessere
"ELV*IS" | Parte fissa di ciascuna tessera creata
1001 | Prossima tessera da emettere
"STP-103PG" | Nome della stampante per le ricevute
"Acrobat PDFWriter" | Nome della stampante per i testi
"PDFCreator" | Nome della stampante per le tessere
"10" | Offset verticale delle tessere (mm)
"10" | Offset orizzontale per le tessere (mm)
"D:\Loghi\LogoElvis.jpg" | Immagine da stampare come logo
"D:\Loghi\retro.bmp" | Immagine da stampare sul retro
#TRUE# | Questa macchina può emettere ...
#TRUE# | Questa è l'unica macchina ...
#TRUE# | Verificare la scadenza solo ...
0 | Porta seriale per Lettore BarCode
10 | Numero di caratteri del codice Tessera
0 | Opzioni (no barcode ecc.)
#TRUE# | Questa macchina gestisce in automatico ...
"ElvisControl" | Nome di servizio come Controller
15 | Inviare la presenza ogni ... secondi
23122 | Numero porta UDP di presenza
23123 | Numero porta UDP di servizio
"C:\Programmi\Willer\Errorlog.txt" | File degli errori del Controller
#FALSE# | Criptare le comunicazioni
"Biblioteca.local" | Nome eventuale Dominio di accesso
.-------------------------------------------------------------------------.
" Modificando il numero seguente si riabilita la procedura di primo avvio "
`-------------------------------------------------------------------------'
1375986380 | Codice di verifica integrità del file
***********************************************
* Fine delle dichiarazioni di avvio di Willer *
***********************************************

Nota: (dalla versione 5.3)
il Codice di verifica integrità del file è anche la password speciale da utilizzare per la creazione degli archivi.


Willer - Errori

Errori e rimedi

Qualora all'avvio di una macchina Willer si presenti una finestra tipo questa:

contenente un elenco di macchine e di differenti righe di errori riscontrati si è in presenza di errori di configurazione o di allineamento del sistema.

Le righe di errore possono essere:

  • Sistema dei semafori
    E' presente un problema nella struttura dei files di sincronizzazione.
    Cancellare, dopo aver fermato tutte le macchine Willer in funzione, dalla directory dell'Archivio, specificata nel file Willer.ini presente nella cartella del programma, i files: Willer.smf, Willer_xxxx.wsm, Willer.tes

  • l'unica abilitata a gestire il sistema
    vuol dire che la macchina appena avviata cerca di gestire un sistema Willer mentre esiste già un'altra macchina che è stata dichiarata come l'unica abilitata a farlo.

    Possibili cause e rimedi:

    • Si è avviata una macchina di riserva in contemporanea.
      E' sempre possibile installare una copia di Willer su un'altra macchina da utilizzare qualora la prima dovesse avere problemi con il S.O. ma tale macchina, che avrà le stesse programmazioni della prima, non dovrà essere utilizzata se non in caso di necessità!
      Usare una sola delle macchine alla volta !

    • Si è programmato erroneamente un sistema Master/Slave (o Server/Client) dimenticandosi di disattivare su qualche macchina l'opzione Questa macchina è l'unica dedicata alla gestione del sistema.
      Verificare la corretta programmazione delle macchine

  • già presente come macchina Server
    vuol dire che la macchina appena avviata cerca di operare come Master (Server) mentre esiste già un'altra macchina con la stessa funzione.

    Possibili cause e rimedi:

    • Si è avviata una macchina Master di riserva in contemporanea.
      E' sempre possibile installare una copia di Willer su un'altra macchina da utilizzare qualora la prima dovesse avere problemi con il S.O. ma tale macchina, che avrà le stesse programmazioni della prima, non dovrà essere utilizzata se non in caso di necessità!
      Usare una sola macchina Master alla volta !

    • Si è programmato erroneamente un sistema Master/Slave (o Server/Client) dimenticandosi di disattivare su qualche macchina Slave (Client) l'opzione Questa macchina può emettere le Tessere e modificare i Listini.
      Verificare la corretta programmazione delle macchine

  • un Controller con lo stesso nome: {......}
    nel sistema sono presenti più macchine abilitate al controllo delle macchine associate ma tali macchine devono avere un differente nome del Controller.

    Possibili cause e rimedi:

    • Si è avviata una macchina riserva in contemporanea.
      E' sempre possibile installare una copia di Willer su un'altra macchina da utilizzare qualora la prima dovesse avere problemi con il S.O. ma tale macchina, che avrà le stesse programmazioni della prima, non dovrà essereutilizzata se non in caso di necessità!
      Usare una sola macchina destinata al controllo delle stesse macchine associate alla volta !

    • Si è programmato erroneamente un sistema con lo stesso nome del Controller dimenticandosi di cambiare su qualche macchina il Nome di servizio di questa macchina.
      Verificare la corretta programmazione delle macchine Willer e delle relative macchine associate (che, si ricorda, dovranno coincidere!)
Se si ritiene che la programmazione sia corretta si può intervenire, dopo aver fermato tutte le macchine Willer in funzione, entrando nella directory dell'Archivio, specificata nel file Willer.ini presente nella cartella del programma, e cancellando tutti i files presenti (Willer.amw, Willer.smf, Willer_xxxx.wsm, Willer.tmp, Willer.tes) ed in particolare il primo: Willer.amw che contiene l'elenco delle macchine che sono attive in un dato momento.
Lo stesso si può fare se avviando WillerUtilities si ha un messaggio di errore per macchine ancora attive mentre tutte sono state fermate.